MV Agusta Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
306 Posts
Discussion Starter #1
Hi lads im looking for advice,ive just noticed when i start my bike up there is coolant dripping from the housing where the hose is attached (excuse my ignorant names on these parts).I presume there is a seal gone would i be correct,is it difficult to fix and where is the quickest place for a replacement one.Cheers,Philip.
 

·
Registered
Joined
·
658 Posts
It sounds like you need to replace the quick release hose clamp with the normal adjustable hose clamp.
 

·
Vendor
Joined
·
5,330 Posts
See if the coolant is coming from the relief hole under the water pump.
If it is a new water pump seal is required.
 

·
Registered
Joined
·
306 Posts
Discussion Starter #7
Thanks Mitcy i will have a look,if this is the case where is the quickest place to get one
 

·
Registered
Joined
·
306 Posts
Discussion Starter #10
Are there any issues with Star Twin as i get a warning on my computer about an unsecure website when im tring to purchase the parts i need.
 

·
Super Moderator
Joined
·
22,313 Posts
@phillo45: It could just be the picture, but why does that "drip" look to be yellow to me?

I would expect green or blue were it coolant...maybe even red, but not golden...:nerd2:
 

·
Registered
Joined
·
14,490 Posts
?

@phillo45: It could just be the picture, but why does that "drip" look to be yellow to me?

I would expect green or blue were it coolant...maybe even red, but not golden...:nerd2:
I'd say Prestone is more yellow than green

:grin2:
 

·
Super Moderator
Joined
·
22,313 Posts
:crazyeyes:flash::crazyeyes
 

·
Super Moderator
Joined
·
22,313 Posts
Thanks
 

·
Registered
Joined
·
9,955 Posts
Another picture
Very likely the seal has worn..However, being the eternal optimist, I couldn't help but notice an overflow pipe resting on the water pump housing. Are you certain it's not trickling down the coolant overflow tube from the expansion tank ?

Dry it all off and have a look see...:nerd2:

Good luck !

Joe
 

·
Super Moderator
Joined
·
22,313 Posts
@gototjoe: On that side, the hose is from the fuel tank overflow/drain.
 

·
Registered
Joined
·
9 Posts
coolant leak 989r

Phillip, even though you sold your bike, you seem to have had the same leak as i had , but it wasn't the pump failing or the oring on the front of the pump

It was the hose hanging down in the photo which is the radiator spill hose . it was tucked down the left and on a hot day a few

drips made there way onto the cover . so i just moved the pipe so you can see it in future. it can really send a false symptom to you.
 
1 - 20 of 20 Posts
Top