MV Agusta Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
2014 Brutale 675

My coolant is constantly leaking from the overflow tube. I thought it might be from idling around in traffic too long but it keeps leaking after I refill the tank. No signs of leaks anywhere else.

Has anybody experienced this issue? Is it something to do with the thermostat?
 

·
Super Moderator
Joined
·
22,071 Posts
Hahaha, 4 cylinder 675, must be new model. Have a look in the next section down buddy. Lots of discussions on this very topic.
Most probably simply emptying out excess fluid since you should be running the level on low, but it could be a faulty cap or air in the system too.
 

·
Registered
Joined
·
465 Posts
As Donsy says, could be an airlock or faulty cap, but the triples do run on minimal coolant, so if you're topping up all the time it may just be emptying out what you put in.
 

·
Registered
Joined
·
1,726 Posts
2014 Brutale 675

My coolant is constantly leaking from the overflow tube. I thought it might be from idling around in traffic too long but it keeps leaking after I refill the tank. No signs of leaks anywhere else.

Has anybody experienced this issue? Is it something to do with the thermostat?
this is what I do to all the bike I owned, take off the coolant cap start your bike let run to temp 150 degree turn off your bike, then lean your bike to the left shake it couple times and lean your bike to the right shake it couple times then turn your bike on again let it run to temp 160 degree do the same as first step then refill to your coolant to Minimum requirement level recap it ready to go
 
1 - 4 of 4 Posts
Top