MV Agusta Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hi,

I've managed to fix my leaking raditaor and need to refill the system with coolant. It seems the recommend product is AGIP ECO - Permanent. I've looked to buy this locally but can't find it in Sydney. Does anyone know where I can get some or is there an alternate product that everyone is using?

Thanks
Simon
 

·
Administrator
Joined
·
20,056 Posts
Or....

any "Long Life" ethylene glycol coolant 50/50 with water. You can buy overpriced branded motorcycle coolant, or just head to the auto parts store and buy a quality reputable brand there.
 
  • Like
Reactions: silentservice703

·
Registered
Joined
·
14 Posts
Discussion Starter #6
I've filled everything up with Engine Ice and run it up twice till the fan kicks in. It seems to be running much hotter than it was previously and the fan doesn't bring the temp back down. It's sits where the red line is and used to be in the middle of the range. Any ideas?
 

Attachments

·
Registered
Joined
·
105 Posts
Did you totally flush out the old stuff? Look at https://www.evanscoolant.com/
It runs the system at a lower pressure because of the higher boiling point. But you have to get ALL of the other stuff out and cleaned. Maybe your running into the same issue?
 

·
Vendor
Joined
·
5,367 Posts
Sounds like you have an airlock in the system.
Leave the cap off as you are running the motor.
Start the the bike and run until the fan kicks in.
Let it cool down for awhile and do it again.
 

·
Registered
Joined
·
1,699 Posts
Wow that is hot! There are a number of threads about how to burp the cooling system. In summary, fill up to the minimum mark on the header tank, idle whilst tilting the bike from side to side after giving it some time to heat up and open the thermostat. It is a lot easier with a helper to share the load.
Tipping it over allows the air bubbles to move to the highest point. I tapped the engine block with a rubber mallet to move things as well.

I would not run it with the cap off. The water will boil suddenly and make a mess as it boils over. PITA to clean the stain off the motor. Been there done that.
 

·
Administrator
Joined
·
20,056 Posts
Yes, you didn't get all the air out.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #11
Sounds like you have an airlock in the system.
Leave the cap off as you are running the motor.
Start the the bike and run until the fan kicks in.
Let it cool down for awhile and do it again.
This worked a treat and I needed to add another half litre of coolant. I took it off the work stand (rear only ) and tilted it as per the normal stand making the radiator cap the highest point. Added the extra coolant with the engine running and it's now perfect!!! Thanks for the advice
 
1 - 11 of 11 Posts
Top