MV Agusta Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi,

I have a Brutale that will not start when using the Start button. There is no problem to start on roll.
What I have now examine the following:
- The voltage of the battery is 13 V when the bike is not running.
- The voltage of the battery is 14.4 V when idling.
- Start relay click when I press the start button.
- It is possible to toggle between clock and trip counter with start button.

I have earlier thought it was the start button that was faulty, but as it is possible to toggle with it, i assume it's working.

Anybody have a good idea of ​​what it might be? And how to troubleshoot?

- R
 

·
Registered
Joined
·
5,824 Posts
check the connection between the relay and the starter, and also just because the relay is clicking, doesn't mean its working. Check for continuity between the relay pins or trow a new relay on there just for good measure. Also, could be your starter. You will need to put a multimeter on the starter positive terminal while pressing the start button (will need a friend to help since 2 hands will not be enough to accomplish this step) to see if it gets current. If you get current on the starter terminals when pressing the start button, then your starter is dead!
 

·
Super Moderator
Joined
·
22,066 Posts
What year is your Brutale? Model?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
check the connection between the relay and the starter, and also just because the relay is clicking, doesn't mean its working. Check for continuity between the relay pins or trow a new relay on there just for good measure. Also, could be your starter. You will need to put a multimeter on the starter positive terminal while pressing the start button (will need a friend to help since 2 hands will not be enough to accomplish this step) to see if it gets current. If you get current on the starter terminals when pressing the start button, then your starter is dead!
Thanks for the input. I will give it a try after work.

What year is your Brutale? Model?
989R, 08

-R
 

·
Registered
Joined
·
14,407 Posts
?

Ranur;
download the service manual for your bike.....

there is a step by step trouble shooting guide in the manual

:drummer:
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Thanks for the help guys.
I checked the continuity between start relay and the starter, and there was nothing. So I changed the relay, and the bike is starting with the button again. :)


-R
 

·
Super Moderator
Joined
·
22,066 Posts
Nice!
 
1 - 7 of 7 Posts
Top