MV Agusta Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
486 Posts
Discussion Starter #1
looking for thoughts on this subject
i am currently waiting on samco coolant hoses for my 910s
as i have a oil leak at the water pump i will replace the o ring
but as i will be draining the coolant system and taking the radiator off would it
be sensible to replace the cam chain tensioner as it can sometimes get stuck and also replace the gear selector spring,
maybe do a valve check as this has never been done, bike has 9000 miles on and gives me no problems.
its the thought that going to all that trouble and replacing the hoses then a month or to later the selector spring go,s
your thoughts .
 

·
Registered
Joined
·
486 Posts
Discussion Starter #3
that's exactly what i'm thinking
will just replace these hoses when they arrive.
typical me the blue and red hoses 3 week delivery
i went for Gray ones theses are not in stock and have to be made to order
will get them in new year .
 

·
Administrator
Joined
·
20,104 Posts
Gear selector spring on the 910S was never a problem. Valves should be fine at 9000 miles.

Leave the tensioner alone...if it ever "stuck" you will know it as bad things would happen inside your engine. Your 910S has the improved part that was the replacement in the early F4 recall.

As SS703 said....don't fix what ain't broke.
 

·
Registered
Joined
·
486 Posts
Discussion Starter #5
Gear selector spring on the 910S was never a problem. Valves should be fine at 9000 miles.

Leave the tensioner alone...if it ever "stuck" you will know it as bad things would happen inside your engine. Your 910S has the improved part that was the replacement in the early F4 recall.

As SS703 said....don't fix what ain't broke.
thanks for info things i never new every days a school day :smile2:
 

·
Registered
Joined
·
14,534 Posts
?

mv raptor;
Leave sleeping dogs lie.......
Loosen the pinch bolts on the swing arm and retorque them to 15lbft/20Nm:wink2:

I bought my '08 910R with 4,200mi on it
It had EBC pads.......they were replaced at ~35,000mi
The chain and sprockets are original....I clean the chain occasionally with WD-40 I don't lube it
It has Mitch Hub #6 installed
In 33,000mi the valve cover has not been off.....it weeps but doesn't drip.....not enough to fix it

Most reliable bike I've ever owned period!!!!

Tonight.......
 

Attachments

·
Registered
Joined
·
486 Posts
Discussion Starter #7
mv raptor;
Leave sleeping dogs lie.......
Loosen the pinch bolts on the swing arm and retorque them to 15lbft/20Nm:wink2:

I bought my '08 910R with 4,200mi on it
It had EBC pads.......they were replaced at ~35,000mi
The chain and sprockets are original....I clean the chain occasionally with WD-40 I don't lube it
It has Mitch Hub #6 installed
In 33,000mi the valve cover has not been off.....it weeps but doesn't drip.....not enough to fix it

Most reliable bike I've ever owned period!!!!

Tonight.......
Did you have to show ne that pic it reminds me of my written off 910R lol
will be leaving bike alone this reassurance is what i was looking for, already torque rear hub to your spec.:smile2:
 
1 - 7 of 7 Posts
Top