MV Agusta Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hello everyone!

I am new to the forum and in need of desperate help...

I own an Agusta Brutale 750 f4 (2004), and my radiator is not starting at all when it should (around 100 degree C).

I have changed the temperature sensors (the one on the radiator and the one on the engine which shows the temperature on the display) but still nothing. If I give electricity from the fuse panel to the radiator fan, it's starting as it should, but not automatically.

In the user manual of the bike:

If there is a fault in the functioning of the cooling fan, proceed with the following check:
• Check the condition of fuse 7; - Checked, it's fine
• If the fuse is in good condition, check the cooling fan relay mounted on the right side of the motorcycle as indicated in page 38.

If the relay is in good condition but does not become excited, disconnect the connector of the temperature sensor marked by an M on the lead. Make a bridge between the two contacts as shown in the figure.
. With the ignition switch in the “ON” position the fan should operate and the voltage at the Yellow- Black/White lead of the fan relay connector should be 12V. Made bridge but fan does not start

Any ideas at all?

Thanks!
 

·
Super Moderator
Joined
·
23,940 Posts
@simonfi.andras: I believe the words in the manual are incorrect. The wiring diagram for your bike ('04 Brutale 750) shows the fuse for the fan motor to be F-6, not 7. Additionally, the circuit does not show a relay. The fan motor has a starter that should be fine as the fan starts when 12VDC is applied directly. The fan is controlled by the ECU from the ECU Water TEmperature Sensor.

My advice would be to check fuse F-6 continuity.

I'd like to welcome you to the forum! Your initial post, although with and issue for your bike, is well written and contains all of the pertinent information for us to try and help you remotely. Thank-you for that!

Now, if we only knew where you live on this Big Blue Marble...there may be local help.

If you were to add your bike (Model and year) to your signature line and put a general world area for your location in your profile, this would be helpful in the future. You can do this though User CP.

Please check Fuse 6 and we'll see what we can do to help.

Chuck
 
  • Like
Reactions: simonfi.andras

·
Old Wing Nut
Joined
·
21,954 Posts
Welcome to the family !!!!
 
  • Like
Reactions: simonfi.andras

·
Super Moderator
Joined
·
23,940 Posts
Welcome to the forum!
Bine ai venit in lumea MV!

P.S. Feel free to contact me if you think I can be of any help to you!
A great example of how posting your location can be helpful! :wink2:
 
  • Like
Reactions: Laurtm1

·
Super Moderator
Joined
·
23,940 Posts
@Naabrid: Please describe your issue.
 
1 - 9 of 9 Posts
Top