MV Agusta Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi Every body
Well after inversion of battery plus/ minus ihttp://www.mvagusta.net/forum/images/smilies/lightning.gif don t have any more RPM ,light beam, clock . but the bike is going well, i drive it every day.
My Mv mecanics tall it s the SPU box so we change it but nothing change the bike still going well.
Can somebody help me.
 

·
Registered
Joined
·
14,500 Posts
?

Welcome....

what color is the back of your SPU?

the 2nd sticky in the B4 Section lists the part number......it goes by VIN ONLY

:popcorn:
 

·
Registered
Joined
·
74 Posts
What year and model of Brutale do you have?

Also, what model # is your SPU? Does it have 13 or 12 fuses?

Go to Donsy's website and download the manual for your appropriate bike. http://www.teamdouble3racing.com/manuals.php

I can't answer on the light beam issue.

Workshop Manual ed5

Page 211 shows:
"RPM INDICATOR
If the r.p.m. of the engine is not signalled on the instrument panel with the engine switched on, check:
- The continuity between pin (16) of the instrument panel and pin (20) of the CPU.
- If the cause is verified, the fault will be found in the CPU."

If your bike is running fine and no RPM reading, your CPU = ECU is suspect. No RPM won't allow the multi-function display to work. When the engine is running, every time you hit the start button, it will try to activate the starter again instead of toggling through the display to show the clock, odometer, trip 1 or trip 2.

Try swapping in a functioning ECU from another Brutale. I'm guessing you have the Magneti Marelli 1.6M.

You can also use the 1.6M from Ducati 748, 916, 996 ST, ST4 if you swap in your Brutale Eprom. Click here and read MV Agusta FAQ. You'll want to check and set your idle trim if you use the Ducati model ECU.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Hi APU
My SPU is a 12 and new fron last week.
This is axactly what you describe on the ECU.
Thank you very much for your answer, i gone look for ECU know.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Hi dons
It s a 2007 and the ECU is on the air filter box.
i am not sure wich euro is it? Magneti minarelli I AW 1.6M. AT/ MU23-B36
i find one with the corse Eprom but i don t have race exhaust would it go?
 
1 - 7 of 7 Posts
Top