MV Agusta Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
403 Posts
Discussion Starter #1
Anyone put Arrow Mid-Pipes on with the stock exhaust. Hate the original set-up with the bulky mid section. Is it necessary to put a chip in , or is it ok to just bolt them on and go?
 

·
Registered
Joined
·
312 Posts
i replaced the cat with the inox one from emoto (without EPROM) , tought arrow did not supply EPROM but its not realy needed . I dont need one anyway .....
can't realy tell 'bout increased HP but the sound . ... .damn ....

even without EPROM there is still need for some finetuning dough
(airflow, gas n stuff i guess)
 

·
Registered
Joined
·
1 Posts
I replaced the cat with the arrow midpipe on my 750 Brut and it runs fine without a re-chip. (Bear in mind I'm based in Singapore where its always 30 degrees celsius and 90% humidity) I'm thinking of fitting a BMC filter but not sure how that will affect fueling though. Since the headers and the and mufflers are stock, I'm curious as to whether a re-chip will be needed. Anyone with experience on this?
 

·
Registered
Joined
·
2,291 Posts
Arrow pipe only, and when my bike was dyno'd it was perfectly fine, if not STILL running a little on the rich side. So I can only imagine how it ran with the cat....

You're fine with just a pipe.
 

·
Registered
Joined
·
1,179 Posts
In my case, the Arrow pipe caused a big drop in low to mid speed throttle response. I passed on the Arrow chip but bought a chip from Brad Black at Moto One in AU. Superb throttle response all the way across the board and much omproved driveability. All thumbs up.
 

·
Registered
Joined
·
80 Posts
arrow mid pipe

got an arrow de-cat mid pipe and want to fit it to my f41000r what do i need to do to fit it is there an sensor i need to remove or plug?:naughty: thanks guys
 

·
Registered
Joined
·
56 Posts
This is actually a very timely thread for me, thanks jdog for starting it! I just got my bike back from my local dealership for a 6k service. While they were at it I asked them to remove the Arrow twin exhaust cans and replace them with the original stock, felt the Arrows were just too loud for me.

I asked the mechanic what this would mean in terms of the EPROM chip and he said he'd look into it while doing an overall tune to the bike with the stock back on. When I picked the bike up he said there wasn't much he could figure out as far as the EPROM was concerned as it had no label on it.

The bike runs great, but I definitely feel like I've lost a bit in terms of torque, not surprising losing the Arrows though. I'd like to get some of that grunt back in terms of torque any suggestions?

And what about the no label EPROM issue, I was under the impression that a mechanic could figure out all the details of an EPROM by just hooking it up to a computer and finding out what's what? Can anyone shed some light on the EPROM issue and whether or not something like a Power Commander might help me get some of that torque back?

Thanks.
 
1 - 10 of 10 Posts
Top