MV Agusta Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
202 Posts
Discussion Starter #1
Any idea how much an alternator installation should be?...Plus another flat rate for doing my forks which is $225.
 

·
Registered
Joined
·
819 Posts
If the 225 includes parts, oil, labor that doesn't sound to bad for Agusta forks. Its about on par with FL rates. Depending on where you are in the country this may be different though.
As for how much to install an alternator that is somewhat subjective. If you search through threads on here you'll find several different suggestions for doing an R&R. However is an MV dealer is doing it chances are they will be going by the book and charge the full timed rate. Hope you aren't paying shop rates for someone that hasn't done this before to learn on your bike. Could actually end up being even more expensive.
If you are somewhat mechanically inclined i'd suggest you have a good look at some of the threads on here about installation and see if you feel you can do it yourself. Plenty of folks around to help you out if you get stuck. Downloading a manual will go a long way to understanding what is involved too.
 

·
Registered
Joined
·
14,495 Posts
alternator installation?

taper41;
Chris (X81) posted about removing the alternator by removing the starter and rotating the alternator out
installation would be just the reverse

use search to look for his post
 

·
Super Moderator
Joined
·
22,071 Posts
Nothing about being an electrical mastermind involved in swapping the alternator mate, just a hand full of wires and a plug or two, it's the mechanical skill's involved that will get you stuck. Sound advice from the guys above, this had been discussed at length, so a bit of a search might bring up results you need.
I see you're still struggling with the bike stalling ?
 

·
Registered
Joined
·
202 Posts
Discussion Starter #6
Donsy, Different issue, for some reason It will not let me make a new thread. I had a problem with te EBS Relay and it seemed to solve a few other issues that the bike had I was wondering f there was someone that might be able to explain if it was just a coincidence or not
 

·
Registered
Joined
·
202 Posts
Discussion Starter #8
Yes donsy, it seems to have ... The bikes idle is much smoother ... it actually runs at idle without cutting out It has not stalled at all . plus before I replaced the relay the turning signals would not work. And now miraculous after the replacement they work perfect......... Im not sure how the relay can have anything to do with either of those two things~ !
 

·
Super Moderator
Joined
·
22,317 Posts
Taper, if you can't start a new thread, it is most likely a "compatibility" issue. Make sure your browser is running in "compatibility mode". There are threads about it .
 
1 - 9 of 9 Posts
Top