MV Agusta Forum banner

1 - 20 of 29 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter #1 (Edited)
Entered a roundabout after being hard on the brakes with clutch in for the last part as I dropped down a few gears and ready to engage again ... leaned the bike whilst engaging clutch and no drive, nearly fell off! The engine had stopped ... started it again with the starter and I was away bloody sharpish as there was a lorry aimed right at me ffs! Similar thing happened when changing gear a bit slowly going down hill through a slight bend at quite slow speed with not a lot of braking on that occasion, the rear locked and swung round a bit, pulled the clutch, hit the starter and away again. Dangerous ...!!
 

·
Registered
Joined
·
215 Posts
check out my thread, i have had a right game with my 990r that's how mine started, now the engine has gone completely. same thing when slowing down , drop[ed agear a had no gears them slurred to a halt. they reckon it was the return spring and replaced it for a upgraded part but it was to late engine beyond repair. get it to shop and don't rest untill they change the spring! or fix the whole thing, i'v been mucking about now for just over two months.

good luck.
 

·
Registered
Joined
·
405 Posts
Similar thing happened when changing gear a bit slowly going down hill through a slight bend at quite slow speed with not a lot of braking on that occasion
My 1090 has done this a couple of times, cut out when changing down, into a corner, braking hard, makes me wonder if its the tilt sensor....but only a guess.
 

·
Registered
Joined
·
69 Posts
Discussion Starter #5
My 1090 has done this a couple of times, cut out when changing down, into a corner, braking hard, makes me wonder if its the tilt sensor....but only a guess.
My first thought was fuel starvation as it has happened a couple of times whilst running in on low fuel braking for a junction square on ... but the time entering the roundabout was with 1/2 a tank of juice!
 

·
Registered
Joined
·
69 Posts
Discussion Starter #6
check out my thread, i have had a right game with my 990r that's how mine started, now the engine has gone completely. same thing when slowing down , drop[ed agear a had no gears them slurred to a halt. they reckon it was the return spring and replaced it for a upgraded part but it was to late engine beyond repair. get it to shop and don't rest untill they change the spring! or fix the whole thing, i'v been mucking about now for just over two months.

good luck.
Hi, looked at the thread and this is a different problem. My bikes already been with the dealer for near on 3 months mainly due to not getting the parts quick enough which eventually ended with a new set of instruments after 650 miles so don't want that again now I have it back!
 

·
Super Moderator
Joined
·
22,072 Posts
-10

My 1090 has done this a couple of times, cut out when changing down, into a corner, braking hard, makes me wonder if its the tilt sensor....but only a guess.
Not the tilt sensor, not even sure the 1090's have one ?
 

·
Registered
Joined
·
215 Posts
they do love to hang to them don't they.

I mean we by them to ride them not have them sit around the work shop.
But when i ordered after market parts, hugger, frame protectors, there in two days. mmmmmmm! something wrong some where.
 

·
Registered
Joined
·
3,494 Posts
buy a powercommander,this will sort it out,mine used to do the same thing but on a 1078,very Dangerous.throttle response is fantastic now.has not stalled once.
 

·
Registered
Joined
·
851 Posts
eddy - just fitting a PC won't sort a euro3 low rpm problem - Balancing throttle bodies set CO and TPS will...
 

·
Registered
Joined
·
147 Posts
I have experimented the same problem...so, what it is the solution?

I do not want to buy a PowerCommander if the problem in on the bike...warranty MUST cover this issues!!!

I will comment to my mech when passing the 6K revision...
 

·
Registered
Joined
·
851 Posts
celica I do not believe (I may be wrong & hopefully the clever people will be along soon) a PC will fix very small throttle problem on a euro-3 onwards bike
I had this on my 1078 when very new and was fixed by balance throttle bodies and reset TPS No problem for 5k mls now - It may be the 990R has a different 'problem' but warranty/service must fix this situation
 

·
Registered
Joined
·
69 Posts
Discussion Starter #13
celica I do not believe (I may be wrong & hopefully the clever people will be along soon) a PC will fix very small throttle problem on a euro-3 onwards bike
I had this on my 1078 when very new and was fixed by balance throttle bodies and reset TPS No problem for 5k mls now - It may be the 990R has a different 'problem' but warranty/service must fix this situation
Just heard from my dealer who has heard from Moto GB that this is a known issue with a small number of 990R Brutales and the ECU which has an updated map is to be replaced under warranty .. not bad and pleased with the response as I reported this yesterday!
 

·
Registered
Joined
·
147 Posts
celica I do not believe (I may be wrong & hopefully the clever people will be along soon) a PC will fix very small throttle problem on a euro-3 onwards bike
I had this on my 1078 when very new and was fixed by balance throttle bodies and reset TPS No problem for 5k mls now - It may be the 990R has a different 'problem' but warranty/service must fix this situation
My problem is not very small throttle...my problem is the engine suddenly stops when gears down and braking...

So I hope and ECU map update will resolve the problem as BlackNinja comments.
 

·
Registered
Joined
·
3,494 Posts
hey total , thanks for the advise,mine came with map number 2 loaded and i found the throttle response was much better,so i decided to load map 3 from the power commander site and guess what better again, and i do not even have a race ecu fitted, so it is now just about perfect,but my next step is to take it to ozzy at carina and get my own custom map.using powercommander5.worth everycent.ps:when you look at both maps 2 and 3 together map 3 has values from throttle 2 to i think 20 percent on, map 2 has 0 values in that range.anyway works for me,very easy to use.thats my 2 cents worth.
 

·
Registered
Joined
·
851 Posts
Celica/Ninja - That is the best news as it seems there is 'known' problem - hopefully you guys will get this resolved ASAP - used to scare the sh*t out of me when mine did it :wtf:
 

·
Registered
Joined
·
324 Posts
had that problem on my hypermotard from new, put a pipe/chip in it, TPS, etc... and it made no difference so I got rid of it. I don't have the problem on the 1090. Good luck getting it sorted out - it's a distressing problem to say the least.
 

·
Registered
Joined
·
147 Posts
This issue can be corrected with a fine setting of the fuel injection...I got it under the 6K revision.
 

·
Registered
Joined
·
422 Posts
My 1090 has done this a couple of times, cut out when changing down, into a corner, braking hard, makes me wonder if its the tilt sensor....but only a guess.
Wow just experienced this...Down shifting prior to a corner and braking hard and the power just cut off. (I have less than 2K on the Odo)

Curious what "mode" on the ECU where you in when this occurred? I recently switched from "sport" to non sport just to try and that is when I did notice the power cut off. In fairness I don't recall the same scenario while in sport mode though.

I plan on calling the dealer but in the meantime did anyone here in the US get this fixed by MV? and what was the remedy?
 
1 - 20 of 29 Posts
Top