MV Agusta Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,216 Posts
Discussion Starter #1
Despite the efforts of the MV dealer, new throttle bodies, sensor and re-mapped, bike still hunting/surging between 2000/5000 rpm, which makes uncomfortable riding in towns and traffic.

Any other members experiencing similar problems?
 

·
Administrator
Joined
·
19,804 Posts
Probably some fine tuning needed by the factory..... when the 2008 (2007 Europe) 910R came out, the first of the bikes with the 5SM ECU, o2 sensor, and evaporative emissions canister (in the USA), it had a pretty bad surge in the same rpm range.

Factory came out with an updated map for the ECU that cleared it right up.

Euro4 has added new emissions regs. I will wager those changes will need fine tuning too.
 

·
Registered
Joined
·
605 Posts
My 18 Brutale 800RR runs fine. No problems at all, also with the MWR filters installed.
 

·
Registered
Joined
·
1,658 Posts
Maybe they must reflash the map and calibrate the RBW.

I had a similar issue with my brother's B3 675 a few years back. They loaded the latest map at its first service.

The next time we rode it (we put it on a trailer to the service and back so didn't ride it on the same day) we had terrible mid throttle transition and incredibly high fuel consumption. The motor also hunted in the 2-5000 rpm , especially cruising on the highway.

We took it back, they reloaded the map and calibrated the RBW and problem solved.

Not sure if its the same underlying issue as yours, but worth a try.
 
1 - 6 of 6 Posts
Top