MV Agusta Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I'm new to MV, my first one. Only been on 3 times, but already have to take it back to the shop. The error was STOP. FAULT. Injector Blow. Wouldn't/won't start up. Found a leak/smudge by the gear shifter. Has anyone had this issue before? If so, what was the fix? Parts needed? Attached a couple of pics.
 

Attachments

·
Registered
Joined
·
661 Posts
Dam that sucks. Have them give u new one. I bought a VW Cabrio once. It had stuck fuel gauge several days later. Brought to dealer to repair. Sales saw me and swiftly gave me another brand new on from the lot and updated all my paper work. Talk about integrity selling new, it should act like new!
 

·
Registered
Joined
·
62 Posts
Does it say just "Injector 3 low", or does it cycle between other errors? I had the same message among others when the fuel pump fuse was blown
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
@Fragile and Paors. Yes, only injector 3 low, no other errors come up. I took it to the shop today. They are ordering a new fuel injector. They said everything was connected fine and no blown fuses, but that the hydraulic system kept it open and it put a "choke-hold" on the engine which is why it wouldn't start. They were finally able to clear the code by messing with the wires and was able to get it to start up, but didn't want to give the OK on it and then it happen again. So they will order a new part and do an oil change to make sure everything is I hope to have it back in the next week or two.
 

·
Super Moderator
Joined
·
21,464 Posts
Thanks for keeping The Comunity informed!
 
1 - 8 of 8 Posts
Top