MV Agusta Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter #1
just got my bike a few weeks ago havent hardly put 200 miles on it ....now im having the following issues , can anyone help

1. the throttle isnt responding ...as in i can twist the throttle a full turn and get low revs at around 200 rpm .

2. when starting more than often i get high revs and the engine keeps climbing until i play with the throttle a few times then it idles low as expected.

3. i recently had a dash indication saying "mechanical failure "

mind you im not running it any high rpms or revving the engine at high rpms when stopped .

i just purchased this bike new with only 34 miles on it and ride it maybe once a week and its always an issue .... several times after i stop at a traffic signal then accelerate the i get low revs in first gear as if the engine is struggling ......can anyone help because i mmost definetly am going to ship it back to the dealer to see what this issue is .......all fluids are ok and it was serviced before delivery and im super pissed ......
 

·
Registered
Joined
·
465 Posts
Sounds like the throttle pot has a bad connection or has failed. You say it has always done it? Should have gone straight back to the dealer. That's why they warranty stuff.
 

·
Registered
Joined
·
90 Posts
Discussion Starter #4
cool ....i think im going to look at sending it to the dealer and they can give it a good once over
 

·
Registered
Joined
·
90 Posts
Discussion Starter #5
Sounds like the throttle pot has a bad connection or has failed. You say it has always done it? Should have gone straight back to the dealer. That's why they warranty stuff.
it doesnt do it all the time , i would say 7 out of 10 times that i ride
 

·
Registered
Joined
·
895 Posts
The ecu is mounted behind the battery box. You have to remove the seat and tail unit, and the fuel tank to access it. If you are going to do it yourself, download the shop manuals from Donsy's site, the link is at the top of this section. You may as well do the connector for the throttle assembly too, it sits above the r/h ram air tube.:)
 

·
Registered
Joined
·
90 Posts
Discussion Starter #8
The ecu is mounted behind the battery box. You have to remove the seat and tail unit, and the fuel tank to access it. If you are going to do it yourself, download the shop manuals from Donsy's site, the link is at the top of this section. You may as well do the connector for the throttle assembly too, it sits above the r/h ram air tube.:)
thanks
 

·
Registered
Joined
·
465 Posts
I've had similar issues with a car before. Throttle worked most of the time, then I got shunting and kangarooing. It just got worse as the pot went. That said the pot was 15 years old..
 

·
Registered
Joined
·
1,188 Posts
Dealer recently diagnosed dead throttle on my B3 and replaced it. Made a huge difference. Throttle still worked but it was inconsistent.
 
1 - 10 of 10 Posts
Top