MV Agusta Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
After removing and replacing both my battery and gas tank I noticed two things - the bike now with start in neutral without the clutch pulled in (used to require clutch-in) and the quickshifter is not working. I'm sure its got to be some electrical connection but not sure what I could have missed. Any ideas?
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #3 ·
thanks for the reply. When I checked the main menu the QS was still activated, though I went ahead and recycled it. Will check again tomorrow if its working
 

·
Registered
Joined
·
37 Posts
I think the clutch switch deactivates the qs, so i would also say check the switch at the lever.
 

·
Registered
Joined
·
5,146 Posts
Disconnecting the battery turns off the quickshifter.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #6 ·
I think the clutch switch deactivates the qs, so i would also say check the switch at the lever.

Bingo. I also installed aftermarket adjustable levers and the profile of the cam on the clutch lever appears identical but it is off just enough not to trigger the clutch sensor. Adding some electrical tape to the profile fixed the problem temporarily. I will probably switch to something more durable like foil tape or glue on a plastic shim
 

·
Registered
Joined
·
1,459 Posts
Nice one, problem solved . Happy days .
This forum is a fountain of knowledge .
 

·
Registered
Joined
·
639 Posts
It's all a learning curve, we learn something new everyday at this place :)
 

·
Registered
Joined
·
895 Posts
Disconnecting the battery turns off the quickshifter.
? It didn't on mine, nor did it lose my TC settings or custom map. The only things that replacing the battery lost were the clock and trip meter reading.
Has anyone else noticed that if you activate the clutch switch (just take up the cable slack without slipping the clutch) in rain mode, you get full power? Don't think MV intended this.:wtf:
 

·
Registered
Joined
·
5,146 Posts
? It didn't on mine, nor did it lose my TC settings or custom map. The only things that replacing the battery lost were the clock and trip meter reading.
Has anyone else noticed that if you activate the clutch switch (just take up the cable slack without slipping the clutch) in rain mode, you get full power? Don't think MV intended this.:wtf:
Interesting. My TC setting and map choice remained as set, but my QS turned off.
 

·
Registered
Joined
·
307 Posts
? It didn't on mine, nor did it lose my TC settings or custom map. The only things that replacing the battery lost were the clock and trip meter reading.
Has anyone else noticed that if you activate the clutch switch (just take up the cable slack without slipping the clutch) in rain mode, you get full power? Don't think MV intended this.:wtf:
Same here. My B was pushed into reset many times while having sprag clutch issues. Never lost TC or custom map settings, always lost clock and trip.

Milan
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #14 ·
mine also only lost clock and trip settings
 
1 - 14 of 14 Posts
Top