MV Agusta Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
301 Posts
Discussion Starter #1
2100 kms on the bike and unfortunately I'm running into some problems already. I'm hoping you fine folks can provide a little advice on what I should do.

The problem: I was out for a ride last weekend, had it wide open and about halfway through 2nd the throttle cut off and an error message popped up. Pulled over and turned it off and restarted it. Error message toggles between 3 messages that read "throttle position, gas position, sensor supply". The throttle is cut off from me operating it and is all over the place at idle. Had to load it up on a truck and bring it home...

I called the dealer right away and I guess there is a software update that may fix it. My problem... I live 700kms from my dealer. I knew I was taking a risk being so far away and buying it but oh well, live and learn.

My questions to you guys. Anyone have something similar happen to them? I would very much prefer to try and fix this at home without having to figure out a means of transporting my bike so far away. Also, is there anyway to update the ecu with the factory update at home? Or at least a cheaper means of updating as opposed to shipping the bike 2 ways 700kms.
 

·
Registered
Joined
·
301 Posts
Discussion Starter #2
Oh and a small update on the Quickshifter not working. Not sure if anyone else has been told this but apparently there is some bolt in the Quickshifter that is grounding the circuit out. This is not allowing the bike to communicate with the Quickshifter thus it not working. My dealer has ordered me this new bolt so we shall see if this remedies the problem.
 

·
Vendor
Joined
·
5,359 Posts
Don't we just love electronics :wtf: Hope you get sorted quickly.
 

·
Registered
Joined
·
1,216 Posts
I suspect you won't be able to fix it at home, for the reason that replacing or fixing a sensor doesn't clear the error. I believe it takes dealer equipment to clear an error in the ECU. Hopefully someone will tell me I'm wrong though!

Si
 

·
Registered
Joined
·
301 Posts
Discussion Starter #5
Yeah that's what I figured Cat, thanks though... I was just wondering if there was any way to get my hands on the dealer equipment or something similar to it that can clear errors/update with factory reflashes.

I haven't taken anything apart yet to take a look because, well, I have no idea what to look for. I also kind of doubt that it is anything "physical" as opposed to a software problem. Was just checking to see if anyone had a similar problem and could give me some ideas of what to look for if I do pull it apart. Apparently the dealer had a similar problem with the F3 throttles and a software update fixed them so I'm guessing the current update will fix it.

Unfortunately right now, it looks like I'm taking the bike there in the back of the truck or shipping it. The only other option I can think of is pulling the ECU and shipping it to them to get the update. Anyone have any other input before I make a decision???
 
1 - 5 of 5 Posts
Top