MV Agusta Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Ex-up Valve drive motor continually fails. Authorised dealer replaces the drive motor and calibrates it. It operates fine for about 12 mths than exhaust valve fault is displayed. Cables and adjuster all secure, nothing has moved. Ex-up valve end up in the mid position every time. Stop restart valve does not return to the closed near closed position. I suspect the drive motor mechanism internal get damage some how or jump a tooth in the gearing
On my third one
Over it.
What is the best rectification to eliminate this ongoing issue
 

·
Super Moderator
Joined
·
22,355 Posts
Start using the search function. There is pleanty of info in the forum that doesn't need to be repeated again. Disconnect the mechanical cables.
 

·
Premium Member
Joined
·
818 Posts
Ex-up Valve drive motor continually fails. Authorised dealer replaces the drive motor and calibrates it. It operates fine for about 12 mths than exhaust valve fault is displayed. Cables and adjuster all secure, nothing has moved. Ex-up valve end up in the mid position every time. Stop restart valve does not return to the closed near closed position. I suspect the drive motor mechanism internal get damage some how or jump a tooth in the gearing
On my third one
Over it.
What is the best rectification to eliminate this ongoing issue

I had mine replaced about a year ago. The gears inside the servo are plastic so they are easily broken if there is any resistance in the valve. At least that what the dealer told me but it does make sense. He said to keep the valve moving freely by lubing it every once in a while. So far so good for me anyway. I'm not sure that if you just remove the cables if that will fix the fault since the sensor is in the servo. I'd be curious to know if you go the route.
 
1 - 3 of 3 Posts
Top