MV Agusta Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi everyone,

I am here asking for your much needed assistance and any help is greatly appreciated.

My buddy picked up a Brutale 920 2 weeks ago. 2012 model. Bike ran fine. He parked it for a few days and went to start it. Battery was flat. Charged and it was fine again. The following weekend he went to start the bike. No response. Dash does not sweep, no fuel pump priming, no headlights, no noises. The only thing that came on is the oil light flashing. Pushing starter = nothing. He bought a brand new battery and made no difference.

I have read all I can on these forums on possible issues (that my limited tech. Knowledge can comprehend) but none quite match his symptoms. I'm going out there on the weekend to try and sort it out with him.

Im going to check:
- all wires hooked up to battery properly and securely
- check grounding
- check all fuses
- check all plugs and looms are secure

If this fails, what else should I look out for?
Solenoid? Relays? A little guidance on what and how to check would be so helpful.


I have spoken to him and he says all fuses appear good, battery hooked up correctly, no revesed polarity at all. No popping or sparking installing battery.

Many thanks.
 

·
Registered
Joined
·
1,737 Posts
Download the workshop manuals from elsewhere on here, then carefully check that all the battery wires have been connected correctly.
Also check the connections on the solenoid, particularly the 4 pin plug on the side.
 

·
Super Moderator
Joined
·
22,871 Posts
The referenced solenoid is the start solenoid located just behind the batter under the seat. There are two fuses on that solenoid...one is a spare and one is live. Check the live fuse with a meter for continuity. If necessary, replace with the adjacent spare and see if that is it.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Thanks for the advice revhead nad silent service. Will do as you have said. Been diggin around for the 920 manual with no luck though. Will keep looking.
 

·
Registered
Joined
·
1,737 Posts
The 920 is a sleeved down version of the 1090 I believe, so you will be able to use that manual as a start point for layout of The electronics.
Team Double 3 Racing | MV Agusta
This is where to go for manuals.
Send a get well card to Donsy, who is responsible for this repository. He is currently recuperating from a broken pelvis.
 

·
Registered
Joined
·
137 Posts
My 920 has only one wire to the positive connection and two on the negative. Check the plug on the back of the clocks.

This quick manual might help.
 

Attachments

·
Registered
Joined
·
14,683 Posts
?

Wilfumi;
There is an electrical trouble shooting guide in the service manual start there:wink2:
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
Oh thank you for the manuals noggin, will look through them. Re: battery wires, noted, will check his battery wiring.

Thank you for the help you guys are great!
 

·
Registered
Joined
·
8 Posts
Discussion Starter #10
Just got back from my buddy's place. Ended up being the most simple thing. He hooked up one of 2 negative wires to battery only. The other wire was somehow tucked underneath some other stuff and was missed.

Happy all round!

Thanks all for the help, and noggin for making mention of the 2 negative wires...spot on!
 
1 - 10 of 10 Posts
Top