MV Agusta Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
Greetings,

I have been having idle and stalling issues with the bike but today after it died at a stop, it would not start again. We push/jump started it to get home but once back in the driveway, it still would not start with the starter switch. All lights come on, fuel pump sounds OK but all I get is clicking noise at the solenoid. I swapped the solenoid from a 2005 model and had same results. I checked continuity of the fuses exposed in the fuse box on the right side of the bike. Battery at 12.8. Disconnected and reconnected the battery. What else should I check before going after the starter?

Any suggestions are appreciated.

One bike down,

Barbara
 

·
Registered
Joined
·
1,511 Posts
First welcome,

12.8 is a little low for the battery, give it a good charge overnight and test again, you need 13.2 really. Might be time for a new battery.

These MV's need the battery in tip top condition, they are intolerant to even slightly lower voltage and cranking capacity. Good luck.
 
  • Like
Reactions: Donsy

·
Registered
Joined
·
5 Posts
Discussion Starter #3
JimboF4, you were spot on... Thank you!. We jump started it with cables to the MG Griso (fresh battery) and it turned over. So, new battery should get her going again.

Happy trails,

Barbara
 

·
Registered
Joined
·
967 Posts
While you are at it check and clean all battery electrical connections including ground lead to the motor, good batteries need good connections and leads and the poor old ground lead is often ignored
 

·
Registered
Joined
·
2,458 Posts
Hey Paul...

My 12 year old (almost 50k km brute) has never had a problem with the kickstand switch.

Cheers
 
1 - 6 of 6 Posts
Top