MV Agusta Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1 (Edited)
Hello everyone...

So to expand on the title, I ordered one of these for my bike. All went fine, but it will not program from 1st gear onward. It will program idle / neutral.

Upon contacting healtech, they say I was supplied the wrong adapter kit (which says for F4 2004 - 2009 I believe). That supplied kit plugged right into my speed sensor as it should. It registers RPM as it should. My speedometer displays the correct speed as it should with the adapter. Logically, that tells me that the adapter harness works.

...The healtech unit just isn't receiving the wheel speed signal. I've unplugged the unit, rerouted, checked connections, etc...no joy.

Now, Healtech wants me to use the kit that adapts their wheel speed sensor. I'm not doing that.

Thoughts / experiences?
 

·
Administrator
Joined
·
20,376 Posts
Gear indicator has to work with wheel speed and crankshaft speed to figure out what gear you are in. Your speed sensor is driven by the transmission output shaft and that should be just fine and the same pulsing waveform as the Healtech sensor that mounts at a wheel (usually using a magnet stuck on a disc rotor bolt).

How is your unit picking up crankshaft speed?
 
  • Like
Reactions: Drewbert34

·
Registered
Joined
·
48 Posts
Discussion Starter #3
Gear indicator has to work with wheel speed and crankshaft speed to figure out what gear you are in. Your speed sensor is driven by the transmission output shaft and that should be just fine and the same pulsing waveform as the Healtech sensor that mounts at a wheel (usually using a magnet stuck on a disc rotor bolt).

How is your unit picking up crankshaft speed?
It's tapped in to the rpm sensor at the plug on the right hand side of the bike. This is the part that is functioning correctly per Healtech's diagnosis / instructions.

Oddly, it is the wheel speed sensor portion of the data feeds that appears to not be registering at the Healtech unit. Why that's odd I'd because I can obviously see that the sensor and plug in adapter work fine as my speedometer registers as it should.

I honestly believe the unit is faulty, but Healtech said that I need to mount their wheel speed sensor, because my MV is a pre-2004.

What difference could there be from 2000 to 2004 that would cause this not to function correctly?
 

·
Administrator
Joined
·
20,376 Posts
What difference could there be from 2000 to 2004 that would cause this not to function correctly?

Absolutely nothing !!! Well, nothing that has anything to do with the speed sensor. Tell them you were mistaken and you actually have a 2005 (it's the same as the earlier bikes too). See what they say.
 
  • Like
Reactions: Drewbert34

·
Registered
Joined
·
48 Posts
Discussion Starter #5
Still not resolved.

Sportbike Track Gear refuses to offer a return stating it's been installed. How the flip would you know if it's bad or not without installing it?

Healtech wants me to install their wheel speed sensor and forgo the factory unit (which works fine). That requires a different harness, which no one has offered to supply. Not only am I not going to install ANOTHER speed sensor, as the bike already has one, but I'm not going to be responsible for purchasing an additional harness just so this POS will work as it is advertised.

Worst customer service experience in as long as I can remember!
 

·
Administrator
Joined
·
20,376 Posts
Harness would just be a couple of wires run to where ever they need to connect. You could put the sensor on the rear wheel or front. Not a fancy harness really.

Do you have their hall affect transistor and stick on magnet??? That is what the wheel speed sensor is. How did you connect the gear indicator into your existing wheel (transmission output shaft) speed sensor?
 

·
Registered
Joined
·
48 Posts
Discussion Starter #7
Harness would just be a couple of wires run to where ever they need to connect. You could put the sensor on the rear wheel or front. Not a fancy harness really.

Do you have their hall affect transistor and stick on magnet??? That is what the wheel speed sensor is. How did you connect the gear indicator into your existing wheel (transmission output shaft) speed sensor?
I have the harness Sportbike Track Gear supplied with the unit. That harness plugs into the factory speed sensor, just like all of the pre 2010 bikes.
 

·
Administrator
Joined
·
20,376 Posts
So you plug into the engine rpm sensor (crank position sensor) AND the wheel speed sensor, right?
 

·
Registered
Joined
·
48 Posts
Discussion Starter #9
So you plug into the engine rpm sensor (crank position sensor) AND the wheel speed sensor, right?
That's correct. RPM signal test Healtech had me perform was successful. Speed sensor test failed; however, all is good with speedometer, so I know the harness is correct and allowing pass through of signal.

I believe the Healtech unit itself is bad. 1st communication w/Healtech was they wanted me to install yet another speed sensor.

I asked Sportbike Track Gear for a refund and was told they couldn't refund installed products.
 

·
Administrator
Joined
·
20,376 Posts
You can test the speed sensor output to the Healtech with a voltmeter. It is just a square wave signal of about 2~3 volts.

Wish you were close by, I would try to help you sort it all out with enough documentation to convince Healtech the unit is defective, if it is.

I haven't installed one of these myself, perhaps there is a wire continuity problem from the sensor connection to the unit?
 
  • Like
Reactions: Drewbert34

·
Registered
Joined
·
48 Posts
Discussion Starter #11
You can test the speed sensor output to the Healtech with a voltmeter. It is just a square wave signal of about 2~3 volts.

Wish you were close by, I would try to help you sort it all out with enough documentation to convince Healtech the unit is defective, if it is.

I haven't installed one of these myself, perhaps there is a wire continuity problem from the sensor connection to the unit?
I can perform that test and I very much appreciate the offer / condolences :) Honestly, I was put off by how all this has transpired and have not researched any further. I will jump back on it this week and update the thread with what I find :)
 
1 - 11 of 11 Posts
Top