MV Agusta Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
i just purchased and 2013 F3, i have been having wo problems with my new bike and it only has 100 miles on it now. i get an exhaust valve malfunction warning about 5 min after riding, it goes away when i shut the bike off and restart it. but comes back on every time i go for a ride. to top it all off now my bike is dead, i have ridden the bike every day so the alternator should of charge the battery in the process. yesterday i was stranded for 2 hours on the road because the bike wouldn't start. bike seems like the battery has no juice so i had to pop the clutch to jump start the bike. what really sucks is the dealership is 4 hours away and 2 full gas tanks worth of travel. it would be nice if there was a simple adjustment to make to solve these issues....PLEASE HELP!!!
 

·
Registered
Joined
·
115 Posts
Hey Sean, Welcome to the club. As far as your Exhaust valve malfunction goes, I had the same issue, along with an Engine malfunction warning and complete shutdown while riding. Some of the F3s are fitted with faulty ECU units and a dodgy wiring loom. I recommend taking the journey to get both replaced under warranty. While you are there it wouldn't hurt to get the gear selector sensor replaced as well. This is also an issue and most probably will show up soon on your bike if it hasn't already. Make sure they replace the ECU with one from a different batch. Good luck.
 

·
Registered
Joined
·
1,760 Posts
Replace the battery (the brand of battery is known for being useless and failing) should be covered by warranty;

You can disconnect the exhaust servo (search the threads here for that), you want to leave it plugged in, but the actual cable running to the valve can be disconnected.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
Called the dealer, they are coming to pick the bike up!! Hopefully these will be the only issues I have!!
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
The dealer said they will look through the bike after they fix the exhaust valve and the battery, but they said they won't replace something that isn't defective yet. Because they said not all bikes have the same problems and if there is nothing wrong at the time of service everything is OK.
 

·
Registered
Joined
·
1,552 Posts
Called the dealer, they are coming to pick the bike up!! Hopefully these will be the only issues I have!!
Sean, who is your dealer? I need to know to shame mine into doing similar. I've read of other's whose dealers have picked up their bikes within a short distance but never one that will travel 4 hours one way.
 

·
Registered
Joined
·
38 Posts
i just purchased and 2013 F3, i have been having wo problems with my new bike and it only has 100 miles on it now. i get an exhaust valve malfunction warning about 5 min after riding, it goes away when i shut the bike off and restart it. but comes back on every time i go for a ride. to top it all off now my bike is dead, i have ridden the bike every day so the alternator should of charge the battery in the process. yesterday i was stranded for 2 hours on the road because the bike wouldn't start. bike seems like the battery has no juice so i had to pop the clutch to jump start the bike. what really sucks is the dealership is 4 hours away and 2 full gas tanks worth of travel. it would be nice if there was a simple adjustment to make to solve these issues....PLEASE HELP!!!
Hi Sean, had similar problems as your too. Just have the lousy battery replace and your bike should starts. As for the exhaust valve malfunction, its the servo motor not doing its job. It doesn't pulls the cable to open up the butterfly valve thus causing bike losing power. I had the cables removed so the valve always stays open. Loss a little little bit of low end tho but not an issue to me. And the exhaust sounds louder and better to me now with a solid sound. New servo motor has arrived and will install when i get bored with the exhaust sound.
 
1 - 7 of 7 Posts
Top