MV Agusta Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
106 Posts
Discussion Starter #1
Hello friends of the oily fingers,

I changed the break fluid from my double scarab break system and the breaking force was excellent. After my second ride (2 weeks later) I noticed that the break worked spongy, than when air inside the system.

I changed a second time to make shure I have worked correctly - but the same (after 2 weeks spongy; air bubbles visible in my bleeder).

I checked all pipes and connections and found nothing. I also found no leak.

My guess is that the vent screw. Has anybody expierence with it and can support me on this?

Should I change all lines, or has it to do with the brake piston?

I would like to solve the problem, because I don't want a Brembo replacement on my bike.....:naughty:

THX in advance,

Helmut
 

·
Registered
Joined
·
3,905 Posts
Helmut I would ask Jörg Bohnenstiel [email protected] he is one of the view, if not the only one, who is a specialist on Scarab, Lockheed, old Brembo and so on. In my eyes it could be leaking on several places. brake caliper, brake piston, etc.
 

·
Registered
Joined
·
576 Posts
Hi Helmut.

Usualy draws air in past the master cylinder piston seals. This often shows up just after a brake bleed as you have moved the piston more than it has been used to.

Another possibility is that the little balls under the caliper bleed screws need changing. This however usualy shows up by leaking a bit of fluid.

As Haupti says, best to go over the whole system.

They never were any good even when new, but then they never were that fast either:)

Dorian.
 
1 - 3 of 3 Posts
Top