MV Agusta Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
238 Posts
Discussion Starter #1
Hi all,
It's been a while since I've beenhere, new job, house move etc.

I'm off to the TT tomorrow, so today, after riding the bike last night, cleaning, polishing, chain adjusted and all nice and just how it should be, roll out the bike, turn the key, wait for the dial, hit the starter........click and f*** all else. Hit the button 2, 3 4 times - nothing happens. 5 th time very feeble click

2 years this bike has not had a problem. The day before I got to the Isle of Man this happens and I'm at work so will be pressed for time.

Any idea where to look anyone please?
Battery is fully charged by the way
cheers,
Hoppy (not happy)
:thewife:
 

·
Registered
Joined
·
7,772 Posts
Could still be the battery. Curtis rode Randy's Brutale for a little ride. About 1/2 later the battery was too weak to start the bike and after the 3rd try would not turn on the dash.
 

·
Registered
Joined
·
238 Posts
Discussion Starter #3
Thanks Andrew, I'll look when I get home. Too late to do anything about it now. Typical if I need new parts.
Just drooling over your new build - very nice! What grips are you using? They look quite thick, I get vibes at around 60mph ish - which is when I'm stuck in traffic, it's completely hand numbing
cheers,
Hoppy
 

·
Registered
Joined
·
14,489 Posts
?

Hoppy;
Have the battery load tested....if it passes

It's a bad connection....clean and tighten them

Then check the charging voltage at idle, it should be 14.5+V

In the case of Randy's bike the bike isn't charging


:popcorn:
 

·
Registered
Joined
·
196 Posts
If the battery and you can't get one anywhere early tomorrow from a bike shop maybe try CES as they sell Yuasa YTZ10S's (OE make/type) and may have one in stock, although not the cheapest at £97 when I looked on the bay just now. If really stuck I have one new boxed pending fitment to my RR312 due to be registered in September, so can spare it and buy another. It can only be the replacement new price though sorry.

Note the OE is 190cca and others can be as low as 145 and not all are suitable to lie flat like the original despite using similar part numbers.

Hope you sort it one way or other
 

·
Registered
Joined
·
238 Posts
Discussion Starter #8
Hi all,

Thanks for all your kind offers and info. I didn't need it in the end. I lifted the seat unit had a look at all the wiring which is all tight. The bike started and hasn't missed a beat since. No idea what it was. Anyway the TT was fantastic and I'm glad that the bike was faultless for the whole week :)
cheers,
Hoppy
 

·
Registered
Joined
·
1,164 Posts
Hi all,

Thanks for all your kind offers and info. I didn't need it in the end. I lifted the seat unit had a look at all the wiring which is all tight. The bike started and hasn't missed a beat since. No idea what it was. Anyway the TT was fantastic and I'm glad that the bike was faultless for the whole week :)
cheers,
Hoppy
Awesome what dates was you over there? I kept an eye for other MV riders. I was out there from the 3rd to the 9th
 
1 - 9 of 9 Posts
Top