MV Agusta Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter #1
I adjusted my chain yesterday as it was getting too loose and while cleaning it, I noticed that the master link is somewhat protruding. It looks like there are two o-rings on each side instead of one. I plan on replacing the chain ASAP. I have ridden the bike ~7000 mi since buying it and have never had an issue, but this is kind of concerning. I've installed chains on my previous bike and it was always flush with the other links.

What do you all think, is this an immediate hazard?



 

·
Super Moderator
Joined
·
22,311 Posts
Interesting, that.

It does appear that whoever assembled the chain added an extra X-ring and didn't quite compress the link to flush.

You've gone 7000 miles, so I don't think you have an immediate issue. As long as there is no interference with other components as it rotates through, you should be fine.
 

·
Registered
Joined
·
81 Posts
Discussion Starter #3
Interesting, that.

It does appear that whoever assembled the chain added an extra X-ring and didn't quite compress the link to flush.

You've gone 7000 miles, so I don't think you have an immediate issue. As long as there is no interference with other components as it rotates through, you should be fine.
Thank you. Yeah, there doesn't seem to be any interference with other components as it rotates, but I did notice that there is some hold up somewhere because there is resistance at two points as I try to rotate the chain through a revolution. That is what actually brought me to discover the issue.
 

·
Super Moderator
Joined
·
22,311 Posts
Is that link able to wiggle axially?
 

·
Super Moderator
Joined
·
22,311 Posts
Good to hear.
 
1 - 6 of 6 Posts
Top