MV Agusta Forum banner

electrical problem

  1. Brutale 910 - Left side indicators and headlight out at idle

    Maintenance & Tech. Issues (All 4 Cyl. Models)
    Hey folks, bit of a weird one this. Started the bike up the other day (laid up over winter), left her ticking over to get up to temp and suddenly the headlight bulb goes off. I assume it's a bulb, but do a quick check of all other lights and the indicators (front and rear) on the left have...
  2. Rivale Tail Light issue

    Maintenance & Tech. Issues (3 Cyl. Models)
    My '14 Rivale just developed a problem where the left brake light will not illuminate during normal running. When I switch the bike on, it lights up normally for about a second and then goes dark. Strangely, it still lights up when I apply the brakes so I know that the bulbs are good.. Has...
  3. 2004 Brutale S Ignition Coil Testing Help

    Maintenance & Tech. Issues (All 4 Cyl. Models)
    All, Please understand that electrics are not what I would call a strong part of my skill set. I have had a coil failure on my 2004 Brutale 750 S and hoping to figure out their condition with them off of the bike using a multimeter. The readings I am getting seem a bit odd, so I am looking for...
  4. 1090R Random Shutdowns

    Maintenance & Tech. Issues (All 4 Cyl. Models)
    Over the past few weeks, culminating in a disastrous ride to work this morning, my bike has been completely cutting out. It runs fine, then once while accelerating and several times while idling at the lights, the engine just stops. No warning, no obvious reason, it just stops. Then the...
  5. Latest problem Really need input

    Maintenance & Tech. Issues (3 Cyl. Models)
    First mv is a 2013 F3 675 I love it but it keep breaking down on me. So the issue is when i turn my bike off and remove the key the headlight and display stays on and when i turn the bike on the headlight turns off, everything else runs normal. The display reads beam relay / can line. I have...
Top