MVAgusta.net - Reply to Topic
Thread: Whitelights integrated turn signals wiring question... help! Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
03-14-2019 07:22 PM
[email protected] I got my Clear Led intergrated tail light/turn signals at http://www.mygpraing.com I was just looking for the box for name brand as it is plug n play unit . Design corse carries same nut I live in USA and ALEX is a site supporter .
03-14-2019 04:28 PM
cccpNyC
Quote:
Originally Posted by jaramharamharam View Post
So the oem light has White, Brown and Black wires, attached to the clip (not sure what thats called). Those three wires attach to the White lights light, which has Black, Red and White wires, in the following order:
Brake light:
F3 White -> WL Black
F3 Black -> WL Red
F3 Brown -> WL White

Turn signals was the confusing one as the oem cabling has Black and Red wires for Left and Blue and Black wires for the Right. The WL signal wiring only has 2 wires, one Yellow and the other Blue. You only need the Black wires from the oem side. I snipped and shrink wrapped them to keep them out of the way.
F3 Black (from the one with the Red) -> WL Yello
F3 Black (from the one with the Blue) -> WL Blue

And thats it. Worked 100%. This might be a simple thing for a season mechanic but it was a head scratcher for me. First time I tried wiring on my bike. Was fun, albeit frustrating, to figure it out.



Glad you got it figured out. I recently ran into the same issue. Did you test the blink rate to see if you needed a resistor? I did with mine.
03-14-2019 02:31 PM
jaramharamharam So the oem light has White, Brown and Black wires, attached to the clip (not sure what thats called). Those three wires attach to the White lights light, which has Black, Red and White wires, in the following order:
Brake light:
F3 White -> WL Black
F3 Black -> WL Red
F3 Brown -> WL White

Turn signals was the confusing one as the oem cabling has Black and Red wires for Left and Blue and Black wires for the Right. The WL signal wiring only has 2 wires, one Yellow and the other Blue. You only need the Black wires from the oem side. I snipped and shrink wrapped them to keep them out of the way.
F3 Black (from the one with the Red) -> WL Yello
F3 Black (from the one with the Blue) -> WL Blue

And thats it. Worked 100%. This might be a simple thing for a season mechanic but it was a head scratcher for me. First time I tried wiring on my bike. Was fun, albeit frustrating, to figure it out.
03-14-2019 02:23 PM
jaramharamharam
Quote:
Originally Posted by silentservice703 View Post
Send AL at DC a message asking for install directions. He is very responsive.
Actually figured out. Will put it here for whomever does a search looking for these answers. What a pain in the ass. Wouldn't have killed them to include a very simple little document in there...
03-14-2019 07:50 AM
silentservice703 Send AL at DC a message asking for install directions. He is very responsive.
03-13-2019 08:28 PM
jaramharamharam
Quote:
Originally Posted by silentservice703 View Post
From what company did you buy the kit?

Can you post a link to it?
https://www.designcorse.com/collecti...led-tail-light
03-13-2019 05:51 PM
silentservice703 From what company did you buy the kit?

Can you post a link to it?
03-13-2019 05:38 PM
silentservice703 So that indicates that the White Lights Turn Signals are grounded to the chassis of the unit.

Running LIght - Hot
Brake Light - Intermittent Hot
Unit Ground
Right Turn Signal - Intermittent Hot
Left Turn Signal - Intermittent Hot

Hook it up so that you don't use the MV Turn Signal Grounds.
03-13-2019 04:20 PM
jaramharamharam
Quote:
Originally Posted by MV Arthur View Post
Splicing necessary unless you have this.
the problem is that there are the 3 main wires that go into the (excuse my lack of actual terms for these adapters) main clip that controls the brakes. thats no problem. but the whitelights unit has only 1 wire per blinker where as the oem wiring has 2 per blinker (one being ground and the other live).

so what do you do??

what i did was merge the blinker grounds coming from the bike to the ground going to the brake light, and attached the live R and L wires. all that did was turn off the brake light when i brake, and flash the brake light when i turn on the signals.

all in all, there are 7 wires coming from the bike, but only 5 on the whitelights unit...
03-13-2019 04:02 PM
MV Arthur Splicing necessary unless you have this.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome