Dragster RR MY19 LED Signal Help - MVAgusta.net
 2Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 24 (permalink) Old 05-06-2019, 01:36 PM Thread Starter
Established Member
 
makers_mike's Avatar
 
Join Date: Feb 2015
Location: Atlanta, GA
Posts: 173
Dragster RR MY19 LED Signal Help

Hey Everyone,

I have installed LED front and rear signals from Watsen Design. I'm experiencing some weird behavior and while Roger and I are discussing solutions, I thought I'd reach out to this community as well to see if y'all may have an answer.

First Setup:
LED Signals front and rear
Each signal has a resistor
Turn bike power on, signals work fine, but Hazards don't work at all
Turn bike over and begin riding, the signals function as normal for a short period of time, then I get nothing (no flashing, no indicator symbol on dash)


Second Setup:
LED Signals front and rear
Resistors on only the rear signals
Turn bike power on, signals fast blink
Turn bike over and begin riding, the signals function as normal (factory blinking cadence) for a short period of time, then I get nothing (no flashing, no indicator symbol on dash)

Has anyone else experienced this and how was it fixed? Do I need more resistance?

Thanks for the help!

2019 MV Agusta Dragster RR
2017 Aprilia RSV4-RF (SOLD)
2016 Aprilia Tuono Factory (DECEASED)
2015 MV Agusta Dragster RR (SOLD)
2013 Triumph Daytona (SOLD)
makers_mike is offline  
Sponsored Links
Advertisement
 
post #2 of 24 (permalink) Old 05-06-2019, 04:09 PM
Established Member
 
Join Date: Jul 2015
Location: NZ
Posts: 149
Hi there.
my 2c: if they were LEDs to start with then you don't need any resistors, but presumably you've tried this and without resistors they blink fast, or show errors on dash (does the hazard function work at that time?).

I'd guess that the flasher relay is electronic and the resistors that you're trialling (in parallel presumably) are of low resistance, and over time the relay is 'tripping out' on overcurrent (though not enough to blow fuses) for want of a better word.

I'd work out what the wattage of each light was and then calculate an appropriate resistance - for example on the older dragster I needed circa 50 - 60 ohms to replicate the 3.6w of each lamp (using VxV/R), but found that I could increase the resistance to circa 200 ohms without error.

Perhaps series up the resistors that you do have (i.e. to double the resistance) and place these in parallel with your LEDs and see if that does work (try this on one side first, so you have more resistors to trial).

Cheers,

NM
Nicklemouse is offline  
post #3 of 24 (permalink) Old 05-06-2019, 04:14 PM Thread Starter
Established Member
 
makers_mike's Avatar
 
Join Date: Feb 2015
Location: Atlanta, GA
Posts: 173
Quote:
Originally Posted by Nicklemouse View Post
Hi there.
my 2c: if they were LEDs to start with then you don't need any resistors, but presumably you've tried this and without resistors they blink fast, or show errors on dash (does the hazard function work at that time?).

I'd guess that the flasher relay is electronic and the resistors that you're trialling (in parallel presumably) are of low resistance, and over time the relay is 'tripping out' on overcurrent (though not enough to blow fuses) for want of a better word.

I'd work out what the wattage of each light was and then calculate an appropriate resistance - for example on the older dragster I needed circa 50 - 60 ohms to replicate the 3.6w of each lamp (using VxV/R), but found that I could increase the resistance to circa 200 ohms without error.

Perhaps series up the resistors that you do have (i.e. to double the resistance) and place these in parallel with your LEDs and see if that does work (try this on one side first, so you have more resistors to trial).

Cheers,

NM
Thanks for the input NM. I was thinking along the same lines as you in regards to the electronic relay. Its time I added a multimeter to my work bench anyways. I will have to give it a go soon and report back.

Thanks!
Michael

2019 MV Agusta Dragster RR
2017 Aprilia RSV4-RF (SOLD)
2016 Aprilia Tuono Factory (DECEASED)
2015 MV Agusta Dragster RR (SOLD)
2013 Triumph Daytona (SOLD)
makers_mike is offline  
Sponsored Links
Advertisement
 
post #4 of 24 (permalink) Old 05-06-2019, 04:14 PM
New Member
 
Join Date: Apr 2018
Posts: 39
No help on the electrical, but curious as to your new light setup look if you wouldn't mind sharing a pic or two.
Cheers
LJCF is offline  
post #5 of 24 (permalink) Old 05-06-2019, 11:37 PM
Senior Member
 
cherche's Avatar
 
Join Date: Dec 2012
Location: Germany
Posts: 578
In Europe we have 3,2 Volt signals. There only is a pretty complicated way to have 12 Volt signals working.
The voltage is printed on the signal, just have a look at the OEM ones, Makers_Mike

I motori sono come le donne, bisogna saperli toccare nelle parti piu' sensibili.......
__________________________________________________ ___________________
2018 Brutale 800RR
cherche is online now  
post #6 of 24 (permalink) Old 05-07-2019, 06:37 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 21,191
Send a message via Skype™ to silentservice703
Your signals, on the later bikes, are controlled by the ECU.

The bike also has a CANBUS electrical system which makes changes very touchy.

Gapalicious 2020 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from TENTATIVELYSept. 30-OCT.4, 2020

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #7 of 24 (permalink) Old 05-14-2019, 04:40 PM Thread Starter
Established Member
 
makers_mike's Avatar
 
Join Date: Feb 2015
Location: Atlanta, GA
Posts: 173
Light has nothing on it useful as far as I can see.

I will try increasing resistance, just needed to order some more connectors to experiment some with what I have here.

Here are some pics of the signals:
Attached Images
    

2019 MV Agusta Dragster RR
2017 Aprilia RSV4-RF (SOLD)
2016 Aprilia Tuono Factory (DECEASED)
2015 MV Agusta Dragster RR (SOLD)
2013 Triumph Daytona (SOLD)
makers_mike is offline  
post #8 of 24 (permalink) Old 06-05-2019, 10:16 AM Thread Starter
Established Member
 
makers_mike's Avatar
 
Join Date: Feb 2015
Location: Atlanta, GA
Posts: 173
Waiting for some new resistors to come in to try.

I also met a guy at a local car/bike show last weekend that mentioned you could get variable resistors on amazon and tune until they work, measure the resistance, then make a permanent resistor.

When i searched amazon, it seems that all I can find was potentiometers, which I'm guessing work similarly to resistors in this application. I haven't pulled the trigger on one yet, but may be tempted if this next round doesn't work.

2019 MV Agusta Dragster RR
2017 Aprilia RSV4-RF (SOLD)
2016 Aprilia Tuono Factory (DECEASED)
2015 MV Agusta Dragster RR (SOLD)
2013 Triumph Daytona (SOLD)
makers_mike is offline  
post #9 of 24 (permalink) Old 06-11-2019, 09:54 PM Thread Starter
Established Member
 
makers_mike's Avatar
 
Join Date: Feb 2015
Location: Atlanta, GA
Posts: 173
Still no luck

Tried a pair of resistors from eBay that another member said worked for their bike, but no bueno for me.

I may just need to get a bunch of different resistors and go to town trying different ones. Not sure what else to do at this point. Seems like I'm in uncharted territory as far as I can tell on 2019 dragsters.

2019 MV Agusta Dragster RR
2017 Aprilia RSV4-RF (SOLD)
2016 Aprilia Tuono Factory (DECEASED)
2015 MV Agusta Dragster RR (SOLD)
2013 Triumph Daytona (SOLD)
makers_mike is offline  
post #10 of 24 (permalink) Old 06-11-2019, 10:36 PM
Established Member
 
NM-1's Avatar
 
Join Date: Sep 2017
Location: Albuquerque, NM
Posts: 113
I have some left over Rizoma resistors you're welcome to have. Had Rizoma LED's on my 910S front and back and only used resistors on the rears.

2019 MV Agusta Dragster 800RR
2007 Benelli Tornado Naked Tre 1130
2009 MV Agusta Brutale 910S (sold)
NM-1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome