2016 Dragster RR starting issue. Help required! - MVAgusta.net
Closed Thread
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 03-25-2019, 12:55 PM Thread Starter
2016 Dragster RR starting issue. Help required!

Hello guys, i am new to this forum and i just recently joined the community. I am highly relieved to have found this forum as i was worried that i have no options left. This forum may just be my last saving grace and i will be greatly in debt if i can get any insight.
The thing is my bike which is 2016 model dragster rr suddenly has this weird issue of not staying on idle, it just shuts off. Bike starts just fine no problem starting but the bike only remains on for just a few seconds and the ignition just cuts off as if i have hit the killswitch.
I have contacted the dealer and the mechanic just checked all possible problems like battery, starter relay, ignition switch, sprag clutch and all electric wires and terminals but to no vain the problem still persist.
Guys any help will be greatly appreciated. Thanks
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 03-25-2019, 12:58 PM Thread Starter
Oh and i forgot to mention bike just clocked 2200 kms only. Weird how can such a problem occur on such a low mileage bike.
post #3 of 15 (permalink) Old 03-25-2019, 01:14 PM
Senior Member
 
Black_Gold_Saw's Avatar
 
Join Date: Jul 2016
Location: Netherlands
Posts: 1,245
New Site Garage
Check if the fuelline isnt blocked when fitting the gastank.

"Mileena"
MV Agusta F3 675 '17 - Matt Avio Grey


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Black_Gold_Saw is online now  
Sponsored Links
Advertisement
 
post #4 of 15 (permalink) Old 03-25-2019, 01:45 PM Thread Starter
Already checked the fuel line. I also cleaned the gas tank as well as fuel pump. Dumped the old gas and filled in new gas still same issue.
[email protected]l.com is offline  
post #5 of 15 (permalink) Old 03-25-2019, 02:08 PM
Senior Member
 
Black_Gold_Saw's Avatar
 
Join Date: Jul 2016
Location: Netherlands
Posts: 1,245
New Site Garage
hm... rereading your first post.

These bikes need to be started with the clutch pulled in.
So double check if you dont have to bike in gear, check if kickstand isnt down when releasing the clutchlever.

Check fusebox for good fit or broken fuse? I believe #1 or #3 is the one that has to do with the fireignition. (DONT QOUTE ME ON THIS!!! CHECK YOUR (Engine/workshop) MANUAL FIRST WHICH NUMBER IT IS THAT CONTROLS IT!!!!!!!)

PS: Im no expert in this. Im just suggesting things that have been mentioned before with similar issues.
Im sure people will come by and try to help you out.

"Mileena"
MV Agusta F3 675 '17 - Matt Avio Grey


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Last edited by Black_Gold_Saw; 03-25-2019 at 02:09 PM. Reason: adding text
Black_Gold_Saw is online now  
post #6 of 15 (permalink) Old 03-25-2019, 02:18 PM Thread Starter
Thanks for your suggestion will definitely check.
post #7 of 15 (permalink) Old 03-25-2019, 02:22 PM Thread Starter
I will post a video as quickly as i can. Hope one of you experts can send me through right direction.
post #8 of 15 (permalink) Old 03-26-2019, 04:52 AM
Senior Member
 
Bruce Taylor's Avatar
 
Join Date: Apr 2012
Location: Hertfordshire UK
Posts: 1,134
Send a message via Skype™ to Bruce Taylor
Another very useful website that you might try www.facebook.com/groups/mvagustaownersandriders/
Bruce Taylor is online now  
post #9 of 15 (permalink) Old 03-26-2019, 06:28 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 19,979
Send a message via AIM to silentservice703 Send a message via Yahoo to silentservice703 Send a message via Skype™ to silentservice703
Quote:
Originally Posted by [email protected] View Post
Hello guys, i am new to this forum and i just recently joined the community. I am highly relieved to have found this forum as i was worried that i have no options left. This forum may just be my last saving grace and i will be greatly in debt if i can get any insight.
The thing is my bike which is 2016 model dragster rr suddenly has this weird issue of not staying on idle, it just shuts off. Bike starts just fine no problem starting but the bike only remains on for just a few seconds and the ignition just cuts off as if i have hit the killswitch.
I have contacted the dealer and the mechanic just checked all possible problems like battery, starter relay, ignition switch, sprag clutch and all electric wires and terminals but to no vain the problem still persist.
Guys any help will be greatly appreciated. Thanks
Please put your location in your profile and your bike year and model in your signature line through USER CP.

You really need to describe the condition more clearly.

Please describe the process from start to shut off in detail.

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs ("Slightly" modded...), '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #10 of 15 (permalink) Old 03-26-2019, 11:51 AM Thread Starter
Its a 2016 model dragster rr. When i first turn on the key and everything appears to be normal on the dash and when i press the ignition switch nothing happens like there is no crank or anything. Then i once again turn off the key and again turn on the key and press the ignition switch the bike starts but it shuts off after 3-5 seconds. I checked and replaced the ignition switch but the issue still prevails. Please help me guys!
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome