Oil Light - MVAgusta.net
 2Likes
  • 4 Post By silentservice703
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-24-2018, 03:06 PM Thread Starter
New Member
 
craigzx9's Avatar
 
Join Date: Mar 2016
Posts: 19
Oil Light

Hi I have had numerous problems with my 2016 Dragster RR from the day I purchased it. but now whilst on tour in Spain the oil light came on, I checked and topped up the oil but is still on. I have replaced the oil sensor switch but no difference. if you check the switch there is polarity from the connector and the outer body and the polarity cuts out when you manually operate the switch, but when fitted there is polarity between the connector and the switch body, indicating there is not enough oil pressure to operate the switch, I have also checked and changed the oil. Can anybody please shed any light on this problem.
Many thanks
Craig
craigzx9 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-24-2018, 03:28 PM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,437
Send a message via Skype™ to silentservice703
Perhaps you actually have an oil pressure issue.....
Teeps, Teeps, airjawed and 1 others like this.

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #3 of 7 (permalink) Old 05-24-2018, 04:11 PM Thread Starter
New Member
 
craigzx9's Avatar
 
Join Date: Mar 2016
Posts: 19
Is this a dealer job. ???
craigzx9 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 05-24-2018, 04:35 PM
Senior Member
 
Allworld's Avatar
 
Join Date: Oct 2016
Location: Boston, MA
Posts: 465
Quote:
Perhaps you actually have an oil pressure issue.....
There is a spring holding the filter cartridge in place, is that spring in correctly?
also are you using the the correct oil weight?

Bikes:

2016 MV Agusta Brutale 800 RR
2015 Triumph Street Triple R
Allworld is offline  
post #5 of 7 (permalink) Old 05-24-2018, 04:53 PM Thread Starter
New Member
 
craigzx9's Avatar
 
Join Date: Mar 2016
Posts: 19
Hi the oil is all correct, and I have not changed the filter, is the spring holding that in?
craigzx9 is offline  
post #6 of 7 (permalink) Old 05-24-2018, 06:26 PM
Senior Member
 
Allworld's Avatar
 
Join Date: Oct 2016
Location: Boston, MA
Posts: 465
Quote:
Originally Posted by craigzx9 View Post
Hi the oil is all correct, and I have not changed the filter, is the spring holding that in?
The spring does not hold the cartridge in, the spring sits on the underside of the cartridge, it keeps it tight and pushed up.... I'm not that technical so I can't explain the entire purpose but I do know it is important.

Bikes:

2016 MV Agusta Brutale 800 RR
2015 Triumph Street Triple R
Allworld is offline  
post #7 of 7 (permalink) Old 05-24-2018, 07:30 PM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 17,373
Send a message via Skype™ to esq'z me
you are certain it is not an electrical connection issue?

DO NOT operate the engine until you confirm oil pressure. Can you get an oil pressure gauge (screw it into the oil pressure sensor hole). Crank the engine with coils unplugged and check for at least some pressure.

Pressure relief valve stuck open? Not common, but someone else had one stuck closed....so I guess it's possible.

On the other hand, if you have been riding for a while with the oil light on, and the engine has not begun the death knock of rod bearing failure yet....then you probably have an electrical fault. Low enough oil pressure to turn on the light results in engine rod failure in a very short order.

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, '08 TT-R110 (Buster) Pam's ride, 2015 Indian Chieftain (Rita) my "low-n-slow", '70 Suzuki F50 (Baby Blue), 2018 Suzuki GSX-S750L8 (Susie Q)
esq'z me is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome