EAS quickshifter issue - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-10-2018, 09:02 AM Thread Starter
Established Member
 
Join Date: Nov 2017
Posts: 97
EAS quickshifter issue

Any ideas/experiences on why a quickshifter wont blip up but blips down fine?

In sport mode so it should go both ways, in fact, historically it has.

(my2015 brutale dragster 800 rr)
Digital is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-10-2018, 09:16 AM
New Member
 
Join Date: Nov 2017
Location: Libertyville, Illinois, USA
Posts: 55
There should not be a blip on the upshift quick shift


Sent from my iPhone using Tapatalk
Mschwechter is offline  
post #3 of 5 (permalink) Old 01-10-2018, 09:19 AM Thread Starter
Established Member
 
Join Date: Nov 2017
Posts: 97
not really sure what you mean...

maybe if I reword the issue to , my quickshifter downshifts correctly but doesnt upshift. any ideas why this might be ?
Digital is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 01-10-2018, 11:59 AM
Senior Member
 
Join Date: Dec 2014
Location: UK
Posts: 581
Quote:
Originally Posted by Digital View Post
not really sure what you mean...

maybe if I reword the issue to , my quickshifter downshifts correctly but doesnt upshift. any ideas why this might be ?
The quickshifter is dodgy, the slightest bit of moisture will make it go haywire. There are many threads that address solutions to this issue.

You can either get a 3rd party better quality one, replace this one with a working one (under warranty if you still have), or you could wait for you current one to dry out and get to a working state, then use some silicone to waterproof it a bit more.

One thing to be sure of tho, make sure that the quickshift function is actually on. The symptoms you described can be easily mistaken. When the QS function is off and you dont realise, you are actually clutchless shifting down, cos you let off the throttle just before you down shift. This gives a false impression that the QS is working. But when you go to QS up, you dont need to let off the gas, so it doesnt work. As you may or may not know, because there is still load on the gears, they will not clutchless shift this way.

Have a quick check in the settings

Kag

Kag

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Kageira is offline  
post #5 of 5 (permalink) Old 01-10-2018, 12:12 PM
Senior Member
 
Gero HH's Avatar
 
Join Date: Mar 2016
Location: Hamburg, Germany
Posts: 520
New Site Garage
welcome to the club.. I had 3 QS replaced I'm on my 4th now... (same Part No as for the Dragster RR 800) luckerly it was at warranty, the next one will be not!! (just 1 month left of warranty ) My choice is the QS from HM !!

HM Quickshifter ? Product Categories ? HM Quickshifters

Greetings from Hamburg

Gero
______________________
2016 Turismo Veloce 800 Lusso
Gero HH is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome