Brutale 920 led indicators - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 08-06-2014, 05:28 PM Thread Starter
New Member
 
Ajmz74's Avatar
 
Join Date: Aug 2014
Location: Stafford
Posts: 9
Brutale 920 led indicators

Evening all 😄
I have a set of led indicators to replace the standard ones on my brute ,
Is there an led relay to replace the standard one on the brutale 920 ?
Or can anyone tell me which resisters i would need ?
Does anyone have any experience in changing to led on their 920 ,

Cheers

Andy
Ajmz74 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 08-09-2014, 11:10 AM
Senior Member
 
BrutaleHornet's Avatar
 
Join Date: Feb 2011
Location: The Netherlands
Posts: 639
No experience with this.
Just give it a try, if the blinking goes fast or if it doesn't blink you'll need a resistor.. !

Cheers,

Joost

Currently riding:
- 2014 Brutale 800 Dragster
- Moto Guzzi California III injection

Sold:
- 2004 Brutale 750
- Some Japanese stuff (everybody makes mistakes
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
)
BrutaleHornet is offline  
post #3 of 6 (permalink) Old 08-12-2014, 10:01 AM
Senior Member
 
eduardo's Avatar
 
Join Date: Aug 2009
Location: Algarve, Portugal
Posts: 1,000
Hi Andy. I installed a pair of led rizoma indicators in my F4, thatīs got probably the same electrics than your Brute, from DesignCorse.uk, and had to come a resistor too.
Your Brute looks amazing, by the way!
eduardo is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 08-12-2014, 10:08 AM
Senior Member
 
eduardo's Avatar
 
Join Date: Aug 2009
Location: Algarve, Portugal
Posts: 1,000
Send an email to Al from www.designcorse.com. He will probably answers you in 2 minutes! And heīs the guy you need for your questions.
eduardo is offline  
post #5 of 6 (permalink) Old 08-12-2014, 05:27 PM
Senior Member
 
Reckler's Avatar
 
Join Date: Apr 2013
Location: Calgary, Alberta
Posts: 1,551
New Site Garage
The 920 should be a MY10+, I thought the indicators were already LED on the MY10s. Never actually pulled mine apart to see.

Speed is relative, but fast is fast.

- 2011 brutale 1090R (Matte pearl white/Black)
Reckler is offline  
post #6 of 6 (permalink) Old 08-13-2014, 12:36 PM
Senior Member
 
eduardo's Avatar
 
Join Date: Aug 2009
Location: Algarve, Portugal
Posts: 1,000
Still, probably needs the resistor to work
eduardo is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome