Water impeller leak help - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 07-23-2013, 08:14 PM Thread Starter
Senior Member
 
R1andrew's Avatar
 
Join Date: Jul 2006
Location: South Carolina
Posts: 7,527
New Site Garage
Water impeller leak help

I am having problems with the seal which goes the shaft for the water impeller. It seems that I have to replace it every year. Last time I even placed a water proof lubricant on it. Need some advise on how to install the new seal when it comes in to prevent this problem next year.
R1andrew is online now  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 07-23-2013, 08:22 PM
Senior Member
 
The_castle's Avatar
 
Join Date: Nov 2007
Location: New Zealand
Posts: 7,342
Send a message via Skype™ to The_castle
Hi Andrew,
I'll PM you Ed's phone number.

It ain't what you ride, it's the way you ride it.
The_castle is offline  
post #3 of 10 (permalink) Old 07-23-2013, 08:26 PM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,054
New Site Garage
Shaft maybe worn Andrew ? Have you got the early waterpump or the later version. I have a few lying around if you want to try another one, some brand new never installed.
Attached Images
 

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 07-23-2013, 08:34 PM Thread Starter
Senior Member
 
R1andrew's Avatar
 
Join Date: Jul 2006
Location: South Carolina
Posts: 7,527
New Site Garage
Newer one in the second picture. If you want to send me one I can PM you my address and pay you for it.
R1andrew is online now  
post #5 of 10 (permalink) Old 07-23-2013, 08:35 PM Thread Starter
Senior Member
 
R1andrew's Avatar
 
Join Date: Jul 2006
Location: South Carolina
Posts: 7,527
New Site Garage
Quote:
Originally Posted by The_castle View Post
Hi Andrew,
I'll PM you Ed's phone number.
Got it on speed dail
R1andrew is online now  
post #6 of 10 (permalink) Old 07-23-2013, 09:03 PM
Senior Member
 
Join Date: Mar 2009
Location: Australia
Posts: 568
Check the bearing on the water pump shaft.
Don't know if it's the same but the bearings on the shaft of my KX dirt bike were worn causing the impeller and shaft to move due to thrust under power and let coolant leak.
The shaft had a groove in it at the seal but I just replaced the bearings with some SKF units and left the shaft alone and all was okay after that.
Hope this helps?
bstar360 is offline  
post #7 of 10 (permalink) Old 07-23-2013, 10:13 PM
Senior Member
 
The_castle's Avatar
 
Join Date: Nov 2007
Location: New Zealand
Posts: 7,342
Send a message via Skype™ to The_castle
It's not surprising to me that this part is giving Melissa trouble on her bike.

It's about the only bloody thing that is still a standard MV Agusta component on this velocipede.


It ain't what you ride, it's the way you ride it.
The_castle is offline  
post #8 of 10 (permalink) Old 07-23-2013, 11:07 PM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,054
New Site Garage
Thumbs up

Quote:
Originally Posted by R1andrew View Post
Newer one in the second picture. If you want to send me one I can PM you my address and pay you for it.
New shaft on the way, I will check if I have seals and bearings also Andrew. PM me your new address, I owe you.

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
post #9 of 10 (permalink) Old 07-24-2013, 04:58 AM Thread Starter
Senior Member
 
R1andrew's Avatar
 
Join Date: Jul 2006
Location: South Carolina
Posts: 7,527
New Site Garage
Quote:
Originally Posted by The_castle View Post
It's not surprising to me that this part is giving Melissa trouble on her bike.

It's about the only bloody thing that is still a standard MV Agusta component on this velocipede.

R1andrew is online now  
post #10 of 10 (permalink) Old 07-24-2013, 05:12 AM Thread Starter
Senior Member
 
R1andrew's Avatar
 
Join Date: Jul 2006
Location: South Carolina
Posts: 7,527
New Site Garage
Quote:
Originally Posted by Donsy View Post
New shaft on the way, I will check if I have seals and bearings also Andrew. PM me your new address, I owe you.
This here is why this site is great. PM is on its way.
R1andrew is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome