F4 1000 Randomly Rough Idle - MVAgusta.net
 4Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 32 (permalink) Old 05-07-2019, 11:58 AM Thread Starter
ddn
New Member
 
Join Date: Apr 2019
Location: Minneapolis, MN
Posts: 13
F4 1000 Randomly Rough Idle

I just bought a 2007 F4 1000 R in overall great condition with about 16k miles. It goes like a Falcon 9, which you all of course know. The only issue I'm having is that it will fairly regularly idle rough, when it's not idling perfectly. Regardless of cold or hot, I'll start it up or come to a stop, it'll settle into an idle right around 1200 indicated and idle nicely for a bit and then suddenly start missing and idling up to about 2k. Sometimes it'll stop, sometimes it'll die. If I'm at a light I'll flick the throttle a little and this usually smooths it out enough. I've run a couple tanks of non-ethanol gas through it just to see if that would clear out any old fuel.

I've got the parts to do the fuel filter & fuel line mods & replacement, as well as new plugs. Before I take things apart though I wanted to ask if there is anything else I should be checking while I'm there and have it all apart? As I'm close to the 18k service, I'll probably check the valves while I'm there. I have not reset the TPS.

Also have the appropriate cables to run the diagnostic software, but haven't gotten my hands on it yet.

Last edited by ddn; 05-22-2019 at 10:25 AM. Reason: Mistaken model ID
ddn is offline  
Sponsored Links
Advertisement
 
post #2 of 32 (permalink) Old 05-07-2019, 01:05 PM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,428
Send a message via Skype™ to silentservice703
You are running down the right path.

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #3 of 32 (permalink) Old 05-07-2019, 01:23 PM
Established Member
 
ViggenF4's Avatar
 
Join Date: Aug 2018
Location: Eastern Finland
Posts: 195
I would also balance the TB:s, and check the mixture.

F4 910
ViggenF4 is offline  
Sponsored Links
Advertisement
 
post #4 of 32 (permalink) Old 05-07-2019, 02:10 PM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 17,356
Send a message via Skype™ to esq'z me
Could it be the infamous EBS relay? or was that eliminated on the Euro3 bikes?

I suspect your routine maintenance, and especially the new plugs will take care of it. Putting in Iridiums ??

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, '08 TT-R110 (Buster) Pam's ride, 2015 Indian Chieftain (Rita) my "low-n-slow", '70 Suzuki F50 (Baby Blue), 2018 Suzuki GSX-S750L8 (Susie Q)
esq'z me is online now  
post #5 of 32 (permalink) Old 05-07-2019, 04:47 PM
MVAgusta.net Sponsor
 
mitchy's Avatar
 
Join Date: Feb 2010
Location: Gold Coast, Australia.
Posts: 4,857
New Site Garage
Send a message via Skype™ to mitchy
You could also have a faulty ignition coil.
Look for cracks on the coil stems when you do the plugs.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Bike- F4 1078.
Work.Email & Paypal.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Work Phone (+61)0755244655
Facebook- Mitch Covington
Mobile-0423041326
mitchy is offline  
post #6 of 32 (permalink) Old 05-07-2019, 05:01 PM Thread Starter
ddn
New Member
 
Join Date: Apr 2019
Location: Minneapolis, MN
Posts: 13
Quote:
Originally Posted by esq'z me View Post
Putting in Iridiums ??
I was just going to run NGK CR9EB's.

Quote:
I would also balance the TB:s, and check the mixture.
The TBs I can balance. How do I check the mixture?
ddn is offline  
post #7 of 32 (permalink) Old 05-07-2019, 08:09 PM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 17,356
Send a message via Skype™ to esq'z me
The CR9EI plugs make a big difference....
mitchy likes this.

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, '08 TT-R110 (Buster) Pam's ride, 2015 Indian Chieftain (Rita) my "low-n-slow", '70 Suzuki F50 (Baby Blue), 2018 Suzuki GSX-S750L8 (Susie Q)
esq'z me is online now  
post #8 of 32 (permalink) Old 05-08-2019, 04:47 AM
Established Member
 
ViggenF4's Avatar
 
Join Date: Aug 2018
Location: Eastern Finland
Posts: 195
I had to lean out mine from the factory setting to make it run 100%. Im running the 9EB cos the iridiums quit after 800km. Could have been just random fail though.

F4 910
ViggenF4 is offline  
post #9 of 32 (permalink) Old 05-08-2019, 09:24 AM Thread Starter
ddn
New Member
 
Join Date: Apr 2019
Location: Minneapolis, MN
Posts: 13
Quote:
Originally Posted by esq'z me View Post
Could it be the infamous EBS relay? or was that eliminated on the Euro3 bikes?
I'm not sure but from reading other EBS threads the symptoms sound familiar. I'll take a look at that and the coil packs while I'm there.
ddn is offline  
post #10 of 32 (permalink) Old 05-08-2019, 11:23 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,428
Send a message via Skype™ to silentservice703
Quote:
Originally Posted by esq'z me View Post
Could it be the infamous EBS relay? or was that eliminated on the Euro3 bikes?

I suspect your routine maintenance, and especially the new plugs will take care of it. Putting in Iridiums ??
Quote:
Originally Posted by ddn View Post
I'm not sure but from reading other EBS threads the symptoms sound familiar. I'll take a look at that and the coil packs while I'm there.
No EBS relay on the 312R

Vacuum hose leaks are a possibility though.

Who did your tuning? The 312R (and all MVs for that matter) are quite lean from the factory.....

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125

Last edited by silentservice703; 05-21-2019 at 08:09 AM.
silentservice703 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome