Bought a cheap 990 Brutale with issues. Opinions? - Page 4 - MVAgusta.net
 11Likes
Reply
 
LinkBack Thread Tools Display Modes
post #31 of 34 (permalink) Old 02-24-2019, 04:55 PM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 17,230
Send a message via Skype™ to esq'z me
@[email protected] Did you see the thread where the member was selling his VDST for cheap ???? Buy it !!!

Then you can set (or at least check) the TPS. ..... AND check/set the immobilizer (I am pretty certain there is a screen for that).

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, '08 TT-R110 (Buster) Pam's ride, 2015 Indian Chieftain (Rita) my "low-n-slow", '70 Suzuki F50 (Baby Blue), 2018 Suzuki GSX-S750L8 (Susie Q)
esq'z me is online now  
Sponsored Links
Advertisement
 
post #32 of 34 (permalink) Old 03-13-2019, 10:40 PM Thread Starter
New Member
 
Join Date: Jan 2019
Location: Phoenix, AZ
Posts: 31
Hate to bump this old thread, but I think I’m done with this bike. I admit, I’m a dumbass who fell in love with the looks thinking it was going to be fun bike to ride around on even if it wasn’t perfect. I don’t have the time or technical knowledge to get this thing where it needs to be to be reliable. If anyone lives in the Southwest (US) and wants a smoking deal on a bike that I’ve already put $700 into in parts, PM me an offer. If you feel like you can fix the immobilizer issue, have at it. Have title, all manuals, keys. I can go into detail if anyone is interested. I might as well get a new dragster 800 rr 🤣. Not soured on MVs, just this one.
post #33 of 34 (permalink) Old 04-28-2019, 03:36 PM Thread Starter
New Member
 
Join Date: Jan 2019
Location: Phoenix, AZ
Posts: 31
I’m baaack! Haven’t posted in awhile due to my saltiness with my 990 issues. So I broke down and trailered the bike to the only MV shop here in Arizona. They said only way to fix immobilizer issue is to get new one, keys and lock set. So $1800 later, problem is fixed. Had valves adjusted and throttle bodies synced for another $400. Now, my last and still present issue is the stalling when pulling in clutch to come to a stop. I was hoping the valve work and throttle bodies sync would fix that, but unfortunately, it’s still there if maybe slightly better than before (happens maybe 3-5 times, but probably more if clutching in from higher rpm/gear. No real sputtering, just doesn’t stop the idle at 1k like it should, just goes right past until it shuts off. Good news now is that it starts right back up since no more immobilizer issue. Bike was dropped on left side by previous owner so wondering if anything there as I see clutch switch is bypassed. Idle RPM is slightly low at just a little above 1k. I can keep it running if holding RPM at say 2k and above when clutching to stop, but I don’t want to have to do that as it’s a pain in the ass and not a long term fix. MV shop said plugs were fine and they really couldn’t figure it out. Anything?

I do love the way it rides since I’ve now gotten chance to put some real miles on it. Best feeling bike I’ve ever owned.
Sponsored Links
Advertisement
 
post #34 of 34 (permalink) Old 04-28-2019, 03:55 PM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 17,230
Send a message via Skype™ to esq'z me
Your idle speed is too low. That's why you are stalling from high revs. Should idle at 1250~1350 rpm. Why didn't the dealer address that?
I'm assuming they checked the TPS and it is correct.

There are several ways to go about setting idle speed. The manual would have you adjusting air bleed screws (which is the right way to do it) but that never quite worked for me.

After going through the service manual tuning process several times, I finally adjusted the stop screw on the cable pulley (the one with the yellow paint that means "DO NOT TOUCH").

Gave it about 1/2 turn, opening the throttle plates just a touch...and then reset the TPS (I have the software).

It solved my lumpy idle/stalling/won't stay running when cold problems.
cruiser and theknurl like this.

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, '08 TT-R110 (Buster) Pam's ride, 2015 Indian Chieftain (Rita) my "low-n-slow", '70 Suzuki F50 (Baby Blue), 2018 Suzuki GSX-S750L8 (Susie Q)
esq'z me is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome