F4 750 not firing - MVAgusta.net
 4Likes
 
LinkBack Thread Tools
Old 01-12-2019, 05:17 AM Thread Starter
New Member
 
Le Danoir's Avatar
 
Join Date: May 2015
Location: Lancashire
Posts: 53
F4 750 not firing

I've replaced the cam chain tensioner so the rad's and exhaust are/is off and I just wanted to quickly fire it up to check for noises.

So I've just got the tank and airbox fitted (2 fuel lines and fuel pump plug).

Turns over find, plenty of fuel, the fuel pump primes but it just won't fire up.

Am I missing something?...... the alarm confuses the hell out of me, could that be enabled?
Le Danoir is offline  
Sponsored Links
Advertisement
 
Old 01-12-2019, 06:14 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,422
Send a message via Skype™ to silentservice703
Scant information to go on, but I would check the fuel pump discharge hose in the tank first.

How far did you disassemble?

Did you disconnect and reconnect the battery?

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
Old 01-12-2019, 06:15 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,422
Send a message via Skype™ to silentservice703
There have also been issues with the fuel line quick disconnects not quite being clicked all the way together.

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
Sponsored Links
Advertisement
 
Old 01-12-2019, 06:34 AM Thread Starter
New Member
 
Le Danoir's Avatar
 
Join Date: May 2015
Location: Lancashire
Posts: 53
Bike has been stood for probably a couple of years.

Fresh fuel and I can clearly see the injectors firing with the airbox off.

Typically I can't get my plug socket down the hole as the rubber gaskets are protruding. I'll bob out and try and find a slender socket or I'll trim the gaskets but in the meantime I'm assuming no spark as there's plenty of fuel.

Presumably the ECU won't require signals from the temp sensor on the rad to fire?....... As I've got all of that disconnected.
Le Danoir is offline  
Old 01-12-2019, 06:38 AM Thread Starter
New Member
 
Le Danoir's Avatar
 
Join Date: May 2015
Location: Lancashire
Posts: 53
As far as disassembling, it's been down to pretty much engine and frame while I did some cosmetic jobs........
Le Danoir is offline  
Old 01-12-2019, 06:51 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,422
Send a message via Skype™ to silentservice703
Then you are right to check. or replace plugs...But, since you have had it disassembled, check that you connected the battery with correct polarity and that you actually connected all wires in the correct locations.

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
Old 01-12-2019, 06:52 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,422
Send a message via Skype™ to silentservice703
...and please put the bike year and model in your signature line. As this thread reaches page two, it will be helpful.

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
Old 01-12-2019, 07:52 AM Thread Starter
New Member
 
Le Danoir's Avatar
 
Join Date: May 2015
Location: Lancashire
Posts: 53
So this is where I’m up to.

I connected the temp sensor just in case the ECU needed a signal to fire.
Attached Images
   

MV Agusta F4 750 (MY99)
Le Danoir is offline  
Old 01-12-2019, 08:33 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,422
Send a message via Skype™ to silentservice703
What are you using as a troubleshooting guide?

Have you checked the latch and power relays?

The water temperature sensor, while it feeds the ECU a signal that compensates duration of injection, will not prevent spark from occurring.

The manual has a great troubleshooting section.

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
Old 01-12-2019, 01:01 PM Thread Starter
New Member
 
Le Danoir's Avatar
 
Join Date: May 2015
Location: Lancashire
Posts: 53
OK so now I'm concerned that my timing chain has slipped.

I've taken the valve cover and the crank timing cover off and lined the mark up with the engine casing. Apparently marks on the toothed parts of the cams should line up....... the only marks I can see are about 90 degrees apart!!

There was no mechanical noise and the engine is turning freely.......

erm....... HELP!!

MV Agusta F4 750 (MY99)
Le Danoir is offline  
 

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome