2014 F4 HELP 'exhaust valve' dash warning even with HealTech Eliminator! - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 03-12-2018, 09:53 AM Thread Starter
New Member
 
Erik316's Avatar
 
Join Date: Oct 2015
Location: Idaho, US
Posts: 16
2014 F4 HELP 'exhaust valve' dash warning even with HealTech Eliminator!

Hello all,
I have a BODIS system on my F4 and the cables have been removed from the servo motor upon installation, now after a couple years of riding my dash light for the exhaust valve warning indicator came on. Naturally, I suspected the exhaust valve servo motor was going bad and I bought the HealTech ES eliminator. After I installed it the warning was gone, yah!.

Wait moments into my first ride BAM it comes back on?!?

NOW WHAT?
Any suggestions, Thank you

2013 MV Agusta F4


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
History__________________________________________________ ______________________________________
2010 Kawasaki ZX6R | 2007 Kawasaki ZX10R | 2006 Ducati Sport Classic | 2006 Kawasaki ZX6R | 1999 Ducati Monster
Erik316 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 03-12-2018, 10:05 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 21,197
Send a message via Skype™ to silentservice703
Try this: http://www.mvagusta.net/forum/129-ma...error-fix.html

Gapalicious 2020 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from Sept. 23-Sept.27, 2020

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #3 of 5 (permalink) Old 03-12-2018, 10:19 AM Thread Starter
New Member
 
Erik316's Avatar
 
Join Date: Oct 2015
Location: Idaho, US
Posts: 16
Thanks for the response Silentservice703.
I don't have a servo motor to open up though. I suppose I could check the plug in contacts. That would be a long shot.
I am thinking that there must be some other sensor or something that is triggering the warning.

2013 MV Agusta F4


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
History__________________________________________________ ______________________________________
2010 Kawasaki ZX6R | 2007 Kawasaki ZX10R | 2006 Ducati Sport Classic | 2006 Kawasaki ZX6R | 1999 Ducati Monster
Erik316 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 03-12-2018, 10:32 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 21,197
Send a message via Skype™ to silentservice703
The HealTech doesn't always work.

Gapalicious 2020 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from Sept. 23-Sept.27, 2020

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #5 of 5 (permalink) Old 03-12-2018, 10:57 AM
Senior Member
 
dansoarr's Avatar
 
Join Date: Oct 2015
Location: Herefordshire / Monmouthshire Border, UK
Posts: 725
I agree with @silentservice703 it seems hit and miss with the HealTech, always worth checking the electrical connectors and earths etc.

Only way I have found of guaranteeing no error is to re-flash the ecu to delete the exhaust valve

----------------------------------------
2015 MV F4, ABS
ECU Re-Mapped with ECU studio (F4 RC base ROM)
QS & Blipper now working with ECU studio and Durashift sensor

others
GSXR 1000
GSXR 750
dansoarr is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome