990R Coil, Plug or ECU Issue ? - MVAgusta.net
 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 21 (permalink) Old 02-03-2018, 11:41 PM Thread Starter
Senior Member
 
cruiser's Avatar
 
Join Date: Jun 2007
Location: Auckland, New Zealand
Posts: 2,243
New Site Garage
Unhappy 990R Coil, Plug or ECU Issue ?

Hello family - calling on your experience please.

Three days ago the Brutale started running on 3 cylinders out of the blue... The bike was running rough until I hit about 4000rpm and then it would fire up on all 4 pots. It had been running perfectly fine up until then. However, the day prior had been a pretty damp (not torrential) ride to/from work. As I was on my way to the office I continued to limp along believing it might just a small blip and would clear itself. (the round trip is 60km). The ride home was reasonably rough as well.

Day 2 The_Castle was up in Auckland so we decided to get into diagnostic mode and commenced testing. In our testing mode I quickly encountered a "Coil 2" error on the dash. We removed all the spark plugs and checked the condition of each - we noted that #2 had some weird correction but nothing that looked really out of place. We tested each spark using Coil 1 and confirmed spark on each plug (not we didn't start the bike, we simply confirmed that spark was occurring on each plug via Coil 1. We also swapped Coil 1 and Coil 2 over. Still had a Coil 2 error.

Day 3 I've just replaced all spark plugs - still running on 3 cylinders and Coil 2 error still exists. I then Pull Coil 1 and encountered a Coil 1 and Coil 2 error. I then re-seated Coil 1 and error disappeared however Coil 2 error remained. I then swapped Coil 2 and 1 (yes, the swap included the both the Coil and the plugs below the fuel rail. Restarted bike and Coil 2 error sill occurred. This clearly tells me it's not the actual Coil ...or did I miss something?

I then tested the heat on each of the header pipes and pot 2 header was definitely cooler (not cold) than the others. I have checked the fuses and nothing appears awry.

So in summary it feels like command is inconsistently reaching Coil 2 - without the diagnostic tools I think I've gone as far as I can?

Thoughts please gents? (I don't have any electrical testing gear or should I get an amp meter and see if the female plug to Coil 2 is getting something) ?

...Hope that explains what the hell I've been up too.

Cheers
Tim

Tim
Current
MV Agusta Brutale 1090RR
MV Agusta Brutale 910R - Track Bike
Harley-Davidson Street Glide Rushmore

Past
MV Agusta Brutale 1090RR
MV Agusta Brutale 990R LE Anniversary Edition #81/150
MV Agusta Brutale 750s
cruiser is offline  
Sponsored Links
Advertisement
 
post #2 of 21 (permalink) Old 02-04-2018, 03:45 AM
Senior Member
 
revhead1957's Avatar
 
Join Date: Apr 2011
Location: Brisbane, Australia
Posts: 1,548
2010+ bikes seem to have a habit of eating beru coils.
I presume you have checked compression on no.2?
Change plugs first, being the cheapest option.
revhead1957 is offline  
post #3 of 21 (permalink) Old 02-04-2018, 03:49 AM
Senior Member
 
Deano's Avatar
 
Join Date: Nov 2011
Location: Townsville, QLD
Posts: 744
New Site Garage
Been here a few times. I say coil(s) especially as you've changed all the plugs.

Cheers

Deano
Deano is online now  
Sponsored Links
Advertisement
 
post #4 of 21 (permalink) Old 02-04-2018, 08:35 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,447
Send a message via Skype™ to silentservice703
With the error not following the coil position, I would start checking the lead in to coil #2.
Glenno and Glenno like this.

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #5 of 21 (permalink) Old 02-04-2018, 02:00 PM Thread Starter
Senior Member
 
cruiser's Avatar
 
Join Date: Jun 2007
Location: Auckland, New Zealand
Posts: 2,243
New Site Garage
Quote:
Originally Posted by silentservice703 View Post
With the error not following the coil position, I would start checking the lead in to coil #2.
Thanks Chuck, I feel that it is the next logical step...tracing the lead Uhggg...

cheers

Tim
Current
MV Agusta Brutale 1090RR
MV Agusta Brutale 910R - Track Bike
Harley-Davidson Street Glide Rushmore

Past
MV Agusta Brutale 1090RR
MV Agusta Brutale 990R LE Anniversary Edition #81/150
MV Agusta Brutale 750s
cruiser is offline  
post #6 of 21 (permalink) Old 02-04-2018, 04:59 PM
Senior Member
 
theknurl's Avatar
 
Join Date: Jul 2009
Location: Palos Verdes Est, SoCal, USA
Posts: 13,601
Send a message via Skype™ to theknurl
Thumbs up ?

I'm with Chuck on this one, try some dielectric grease on all the connections

Noel-theknurl

The Forum Curmudgeon
I'm not PC either
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R
'05 F4
ph. 310-414-7247 PST, GMT -8
PayPal;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Skype; theknurl
theknurl is online now  
post #7 of 21 (permalink) Old 02-04-2018, 06:09 PM Thread Starter
Senior Member
 
cruiser's Avatar
 
Join Date: Jun 2007
Location: Auckland, New Zealand
Posts: 2,243
New Site Garage
Quote:
Originally Posted by theknurl View Post
I'm with Chuck on this one, try some dielectric grease on all the connections
Thanks Noel.

Tim
Current
MV Agusta Brutale 1090RR
MV Agusta Brutale 910R - Track Bike
Harley-Davidson Street Glide Rushmore

Past
MV Agusta Brutale 1090RR
MV Agusta Brutale 990R LE Anniversary Edition #81/150
MV Agusta Brutale 750s
cruiser is offline  
post #8 of 21 (permalink) Old 02-04-2018, 06:27 PM
Senior Member
 
theknurl's Avatar
 
Join Date: Jul 2009
Location: Palos Verdes Est, SoCal, USA
Posts: 13,601
Send a message via Skype™ to theknurl
Thumbs up ?

Tim;
Diagnostics has detected a bad connection..... you know the plugs and coils are OK
That leaves the coil wire and connectors for #2

Bet water got in

Noel-theknurl

The Forum Curmudgeon
I'm not PC either
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R
'05 F4
ph. 310-414-7247 PST, GMT -8
PayPal;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Skype; theknurl
theknurl is online now  
post #9 of 21 (permalink) Old 02-04-2018, 09:30 PM Thread Starter
Senior Member
 
cruiser's Avatar
 
Join Date: Jun 2007
Location: Auckland, New Zealand
Posts: 2,243
New Site Garage
Quote:
Originally Posted by theknurl View Post
Tim;
Diagnostics has detected a bad connection..... you know the plugs and coils are OK
That leaves the coil wire and connectors for #2

Bet water got in

I think you're right mate - so is this a compressed air and dielectric grease cleaning approach ?

Tim
Current
MV Agusta Brutale 1090RR
MV Agusta Brutale 910R - Track Bike
Harley-Davidson Street Glide Rushmore

Past
MV Agusta Brutale 1090RR
MV Agusta Brutale 990R LE Anniversary Edition #81/150
MV Agusta Brutale 750s
cruiser is offline  
post #10 of 21 (permalink) Old 02-04-2018, 10:34 PM
Senior Member
 
theknurl's Avatar
 
Join Date: Jul 2009
Location: Palos Verdes Est, SoCal, USA
Posts: 13,601
Send a message via Skype™ to theknurl
Thumbs up ?

Tim;
I think you'll do better with an electric hair dryer and dielectric grease...

High pressure air could drive the moisture deeper, not what you want


Noel-theknurl

The Forum Curmudgeon
I'm not PC either
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R
'05 F4
ph. 310-414-7247 PST, GMT -8
PayPal;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Skype; theknurl
theknurl is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome