16M ECU Repair Option (Australia) - MVAgusta.net
 3Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 25 (permalink) Old 01-01-2018, 04:57 AM Thread Starter
Senior Member
 
Glenno's Avatar
 
Join Date: Aug 2015
Location: Australia
Posts: 653
16M ECU Repair Option (Australia)

Hi Gents, Almost back from a ride yesterday and she stopped dead at the lights.

Was sitting in neutral in some warm (30C) weather with the fan on at the lights. Put her into gear no problems just as I hit the gas steady she stopped. Thought I had stalled it but hadn't.

Pushed her off the side of the road. Bike turned over but didn't start. Whilst waiting for my mate to turn up 20mins later she kicked over but sounded like she was at best running on 2 cylinders
???
2000 model 21000km

Been a bit busy with the family the last couple of days so just pushed her in the garage and haven't looked further. I plan on problem solving it if possible and have developed a list to check:
  • Fuel : purchased from a busy station and had about 100km on that tank. Think it should be okay. But will use a Shell water detection kit.
    Fuel Hoses: Changed 18 months ago and lockwired top hose onto top of fuel pump. Check all hose connections. But when she started poorly on the side of road I could smell fuel.
    Fuel pump: priming
    Coils: I suspect I dropped a coil. So will check those fairly early on.
    Spark plugs :Replaced with iridium 8000 km ago will check.
    Electrical connections...
    ECU/EPROM : Running one of Mercs EPROMS with RG3 and DNA filter. Will possibly try factory one if initial fuel and spark checks are fine.
    Fuel rail and injectors: Could smell fuel when when she started later so I'm thinking they may be okay...
    Mechanical: I don't have the time or tools for that.
Am I missing anything with initial triage?
Ta, Glenno

2000 F4 750

Last edited by Glenno; 04-20-2018 at 08:08 AM.
Glenno is offline  
Sponsored Links
Advertisement
 
post #2 of 25 (permalink) Old 01-01-2018, 07:30 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,514
Send a message via Skype™ to silentservice703
Sounds like a good triage plan.

The usual culprit is fuel supply followed by electrical.

Sometimes the quick disconnects can back out a bit due to wear or pressure from hose routing and cause the fuel to stop being delivered.

What was the last thing done to the bike before this ride?

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
The Following User Says Thank You to silentservice703 For This Useful Post:
post #3 of 25 (permalink) Old 01-01-2018, 04:16 PM Thread Starter
Senior Member
 
Glenno's Avatar
 
Join Date: Aug 2015
Location: Australia
Posts: 653
Thanks mate. I haven't needed to do anything other than ride it for 8000k �� Serviced at 18thou. So I can't link it to any recent work.

2000 F4 750

Last edited by Glenno; 01-01-2018 at 06:37 PM.
Glenno is offline  
Sponsored Links
Advertisement
 
post #4 of 25 (permalink) Old 01-01-2018, 05:41 PM
Senior Member
 
Deano's Avatar
 
Join Date: Nov 2011
Location: Townsville, QLD
Posts: 754
New Site Garage
Glenno,

If it started and ran on two as you say I'd go for coil/coils. I've had a couple suddenly go on me over the years, usually in bastard of places like on runs away to the Atherton tablelands. Plus if you're checking them a full plug replacement is a must while you're in there. Dropped a few plugs as well. A mates 1090 wouldn't start one day and every plug had gone.

Cheers

Deano
Deano is offline  
post #5 of 25 (permalink) Old 01-01-2018, 06:39 PM Thread Starter
Senior Member
 
Glenno's Avatar
 
Join Date: Aug 2015
Location: Australia
Posts: 653
Thanks mate. The plugs were replaced at 14thou with iridium. I'm in Canberra so not a humid environment. I will have a look at them also.Is there anywhere decent to ride on road in Townsville yet? Mount Stuart always had so much potential.

2000 F4 750

Last edited by Glenno; 01-01-2018 at 10:49 PM.
Glenno is offline  
post #6 of 25 (permalink) Old 02-01-2018, 02:21 AM Thread Starter
Senior Member
 
Glenno's Avatar
 
Join Date: Aug 2015
Location: Australia
Posts: 653
Hey guys, I seem to have an intermittent coil on 1&4. Can anyone advise me of suitable new replacements? Did I hear one of the same era Dukes may be compatible?
Edit: On second thoughts they are testing fine.....

2000 F4 750

Last edited by Glenno; 02-01-2018 at 03:40 AM.
Glenno is offline  
post #7 of 25 (permalink) Old 02-02-2018, 10:54 PM Thread Starter
Senior Member
 
Glenno's Avatar
 
Join Date: Aug 2015
Location: Australia
Posts: 653
Has anyone had this problem:

1&4 injectors are not cycling. When carbie cleaner is sprayed into the 1&4 throttle bodies at idle they fire fine indicating fueling is the issue.

Coil and spark is good.

Wiring tests okay.

Thinking it may be ECU related. Have changed the EPROM just in case it had given up, but the problem persists.

Would hooking up Mercs diagnostic software help out there? I haven't used it before.

Anyone Oz side have a spare 750 ECU laying around I could test/buy?

Tips/advice would be appreciated.

2000 F4 750

Last edited by Glenno; 02-03-2018 at 04:34 AM.
Glenno is offline  
post #8 of 25 (permalink) Old 02-03-2018, 06:53 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,514
Send a message via Skype™ to silentservice703
I'd be looking at the diagnostics diagram in the manual, Glenno. There is a section that shows how things get powered up in the fuel injection system through various scenarios.

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #9 of 25 (permalink) Old 02-04-2018, 06:31 PM Thread Starter
Senior Member
 
Glenno's Avatar
 
Join Date: Aug 2015
Location: Australia
Posts: 653
Thanks man, I will look into it.

2000 F4 750
Glenno is offline  
post #10 of 25 (permalink) Old 02-07-2018, 04:37 AM Thread Starter
Senior Member
 
Glenno's Avatar
 
Join Date: Aug 2015
Location: Australia
Posts: 653
Have had a look through the diagnostics and am unable to find anything apart from the ECU that would prohibit the 1&4 injectors cycling. Wiring up to the ECU has been checked for continuity.

2000 F4 750
Glenno is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome