2002 F4 750S cutting out - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 12-27-2017, 04:13 PM Thread Starter
New Member
 
Join Date: Jul 2016
Posts: 11
2002 F4 750S cutting out

Hey guys, got a problem with our MV. It'll suddenly cut out while riding, no back fire, no miss, no stutter, it's as if the kill switch has been pushed. The engine cuts out, and the rev counter drops to zero, the speedo and temp stay working. Then it'll cut back in and either run for a bit, or cut out again.
I've had it on a race stand, held it at 6000rpm and shaken, pulled and pushed on the loom, the fuse box and any other wiring I can grab, inclusding side stand cut out and clutch lever cut out, all good, I've cleaned the fuel tank breathers, and there are no kinks in the fuel lines. Any ideas?
Cheers,
Shane
KiwiMV750S is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 12-27-2017, 05:20 PM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 21,217
Send a message via Skype™ to silentservice703
Tip Over Switch....

Gapalicious 2020 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from Sept. 23-Sept.27, 2020

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #3 of 7 (permalink) Old 12-27-2017, 05:29 PM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 21,217
Send a message via Skype™ to silentservice703
Never mind...it doesn't have one. I'd be checking for loose ground connections. The latch relay could be going bad also...

Gapalicious 2020 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from Sept. 23-Sept.27, 2020

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 12-27-2017, 06:33 PM
Senior Member
 
bioluminescence's Avatar
 
Join Date: Feb 2012
Location: oakland, ca
Posts: 289
New Site Garage
side stand switch. flick your side stand a couple times. if it starts normally, thats probably it. they often go bad, I went through 2 that looked perfectly fine, but the right amount of vibration would kill the bike. $20-$40 on eBay... easy fix.

Nighthawk 650 '83 prune/gunk
FZR 600 '93 red/white
F4 750 '03 red/silver
F3 800 '16 ABS red/silver

Last edited by bioluminescence; 12-27-2017 at 06:37 PM.
bioluminescence is offline  
post #5 of 7 (permalink) Old 12-27-2017, 09:55 PM Thread Starter
New Member
 
Join Date: Jul 2016
Posts: 11
Tested the latch relay, and it's good.
I would have thought if it was the side stand switch it'd put the warning light up on the insturment cluster?
Keep the ideas coming!!
Shane
KiwiMV750S is offline  
post #6 of 7 (permalink) Old 12-27-2017, 10:51 PM Thread Starter
New Member
 
Join Date: Jul 2016
Posts: 11
More symtoms

Found the Neutral light is not coming on now, fuel pump won't prime until the clutch is pulled in.....thinking maybe gear position sensor is faulty...
Shane
KiwiMV750S is offline  
post #7 of 7 (permalink) Old 01-04-2018, 05:38 PM
Senior Member
 
theknurl's Avatar
 
Join Date: Jul 2009
Location: Palos Verdes Est, SoCal, USA
Posts: 14,108
Send a message via Skype™ to theknurl
Thumbs up ?

Shane;
That would be my vote, wait until you see where it is

I made a slotted socket to remove it

Be sure to test the bullet connector for the switch, right rear of motor
Take connector apart, put the bike in neutral, with an Ohm meter check for continuity
to ground on the wire coming from the switch


Noel-theknurl

The Forum Curmudgeon
I'm not PC either
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R
'05 F4
ph. 310-414-7247 PST, GMT -8
PayPal;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Skype; theknurl

Last edited by theknurl; 01-13-2018 at 09:12 PM.
theknurl is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome