common sensor failures 2013 Brutale 1090 RR - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 07-27-2017, 07:19 PM Thread Starter
New Member
 
Join Date: Jun 2017
Posts: 50
common sensor failures 2013 Brutale 1090 RR

so my 2013 Brutale is back at the dealer to fix the poor running issues they are waiting for a rapid bike isolation plug, this so they can test the rest of the bike.
this is essentailly a new motorcycle that the PO has installed a rapid bike ECU and Arrow exhaust system on.

SS I may be heading to MA to see Robs Dyno if this attempt fails
The dealer said they have gotten the bike to run at 80 percent of perfect and that the first 15 percent of throttle travel is where the bike is having issues.
This is exactly where i need the bike to run perfectly
Does anyone have any suggestions on what possible sensors might be bad or failed
or how to proceed to get this machine running the way it should?
I asked about doing a flash program to the original ECU and the dealer said they can not perform that operation only update the factory ECU update.
I really dont want to waste my cash chasing a demn
Otherwise the bike runs great when its past the 15% of throttle under that it stalls and stumbles when at cruising speed say about 70 MPH

2013 Brutale 1090 RR ABS
Philly PA USA
mrmerlin is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 07-27-2017, 07:28 PM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 17,944
Send a message via Skype™ to esq'z me
If the TPS is set correctly then it is probably just the Rapid Bike ECU. Take it off and put the original ECU back on. The only probable sensor that would cause your running condition would be the TPS.

Scrap the Rapid Bike and go see Chuck's dyno man.

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, 2015 Indian Chieftain (Rita) my "low-n-slow", '70 Suzuki F50 (Baby Blue), 2018 Suzuki GSX-S750L8 (Susie Q)
esq'z me is online now  
post #3 of 8 (permalink) Old 07-27-2017, 07:29 PM
Senior Member
 
theknurl's Avatar
 
Join Date: Jul 2009
Location: Palos Verdes Est, SoCal, USA
Posts: 13,800
Send a message via Skype™ to theknurl
Thumbs up ?

I'm with Ed......back to stock ECU


Noel-theknurl

The Forum Curmudgeon
I'm not PC either
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R
'05 F4
ph. 310-414-7247 PST, GMT -8
PayPal;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Skype; theknurl

Last edited by theknurl; 07-27-2017 at 07:34 PM.
theknurl is online now  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 07-28-2017, 02:53 AM
Senior Member
 
revhead1957's Avatar
 
Join Date: Apr 2011
Location: Brisbane, Australia
Posts: 1,567
Second thread by the op about the same issue...

A stock bike is not that bad. Put it back to stock and start again from a known baseline.
revhead1957 is offline  
post #5 of 8 (permalink) Old 07-28-2017, 06:04 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,822
Send a message via Skype™ to silentservice703
@mrmerlin: The first bit of the ECU map is not accessible by any piggy-back tuner. This wa explained in the tuning thread. You need a dedicated tuner to access the ECU mapping and tune the Magneti Marelli 5SM ECU/

You are wasting time money and energy for something that cannot be done as you are proceeding.

This is not a "common sensor" issue. It is the design of the ECU.

Piggy-back tuners also do not adjust the timing tables and that is where a lot of the issue lies. I don't know how many times I can say the same thing. Take the advice of those who have gone before you, or you can waste your time and money.

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125

Last edited by silentservice703; 07-28-2017 at 06:07 AM.
silentservice703 is offline  
post #6 of 8 (permalink) Old 07-29-2017, 06:28 AM Thread Starter
New Member
 
Join Date: Jun 2017
Posts: 50
Hi Chuck i am still learning I talked to Rob yesterday so that gonna be the next stop,
he said he will make the bike run great,.
Thanks for your patience

2013 Brutale 1090 RR ABS
Philly PA USA
mrmerlin is offline  
post #7 of 8 (permalink) Old 07-29-2017, 06:32 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,822
Send a message via Skype™ to silentservice703
@mrmerlin: I will say that my 1090RR is very well sorted by Rob.

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #8 of 8 (permalink) Old 10-27-2017, 01:58 PM Thread Starter
New Member
 
Join Date: Jun 2017
Posts: 50
Well a follow up of sorts, i took the bike to my friends garage for new tires with 2500 miles on the bike,
I fitted the Conti Road attack tires, so far they feel good and handle well.

Anyhow we also removed the rapid bike unit.

Now the bike runs good, low speed engine response is good but not great.

I cant tell if the bike is any slower or not it seems the same to me.

The engine speed issue is still present where turning the throttle from idle to increase results in a jump from 1100 to 2200 RPM it is not incremental like all the other bikes i have.

I also was chasing a no starting issue so i replaced the 3 thick starter wires with a kit from the vendor on here , its very well made and the starter now turns over fast cold or hot.

I also went and replaced the battery as it would allow the bike to be started by jumping the leads at the solenoid but would only result in a click when pushing the starter switch.

even though the original battery was showing 12.4 volts it was not enough to start the bike,
A new battery she starts in a second.

So I am still thinking about taking the bike to Rob over the winter so he can tune the computer,
otherwise I love the bike

2013 Brutale 1090 RR ABS
Philly PA USA
mrmerlin is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome