2013 Brutale 1090 RR poor running issues - MVAgusta.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 07-05-2017, 08:12 AM Thread Starter
New Member
 
Join Date: Jun 2017
Posts: 50
2013 Brutale 1090 RR poor running issues

I have a 2013 Brutale 1090 RR it has an Arrow system on it with a rapidbike Evo tuner,
its been running poorly.
I had a 600 mile service done and the injection system retuned by my dealer,they reset the TPS and cleared the adaptive history.
the bike ran great till I got it home.

I noticed a broken O ring coming out of the throttle cable junction block so I unscrewed the cable turn buckles and took it apart and replaced the O rings.

Little did i know that the cables must be perfectly tensioned to keep the throttle working.

My issues are low speed fueling it seems like when the throttle it opened it is not a gradual engine speed up but rather it goes to 2K RPM it like a switch I can let the clutch out in gear and the bike will moter off without stalling,
I can ride at almost idle speed without the engine stalling.
its when I am shifting gears the engine sounds like its loading up and choking then it takes the gas and goes.

I am still learning how to use the Rapidbike piggyback and i suspect that i might have to reset the TPS

The other issue is that when the bike is cold it will not start and idle for more than 45 seconds till it stalls, I can keep it running with the throttle but it seems like its loading the plugs.
Once the bike gets to temp then it will stay idling could this be a coolant temp sensor going bad?


Otherwise the bike revs great and goes like all get out but trying to maintain a constant speed the on the hiway the engine seems to want to cut out then adding throttle does nothing for a bit then all of sudden the engine comes back to like and takes off

Last edited by mrmerlin; 07-05-2017 at 08:15 AM.
mrmerlin is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 07-05-2017, 08:35 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,794
Send a message via Skype™ to silentservice703
The MV 1090RR Throttle Response is sensitive below 4000 rpm. That being said, certain things help. First, ensure your throttle cables are set to the proper tension. This will have the effect of removing throttle response delay. This will also allow your Cold Start Lever to work. This lever is the little lever on the throttle tube with a +/- on it. It functions to advance the throttle a small amount allowing the bike to run while cold without stalling until it is up to temperature. It's functionality is dependent on the throttle cables being correctly tightened.

Which ECU does that bike have?

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #3 of 18 (permalink) Old 07-05-2017, 06:51 PM Thread Starter
New Member
 
Join Date: Jun 2017
Posts: 50
ECU is Magnetti Marelli 5SM
mrmerlin is offline  
Sponsored Links
Advertisement
 
post #4 of 18 (permalink) Old 07-06-2017, 06:41 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,794
Send a message via Skype™ to silentservice703
The 5SM is tuneable by those with the software and expertise. Were it me, I'd ditch the piggyback system and have the ECU tuned. There is diagnostic software and a cable available to end users to rest TPS and see what is going on. The product name escapes me right now.

Where are you on this Big Blue Marble? You might be surprised at the helpful capacity of people nearby.

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #5 of 18 (permalink) Old 07-06-2017, 10:13 AM Thread Starter
New Member
 
Join Date: Jun 2017
Posts: 50
I am in Philly PA USA,
any one close that knows how to make the adjustments

2013 Brutale 1090 RR ABS
Philly PA USA
mrmerlin is offline  
post #6 of 18 (permalink) Old 07-06-2017, 04:07 PM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,794
Send a message via Skype™ to silentservice703
There is a guy in Gardner, MA that can flash your ECU and smooth it out. Try Robsdyno.com

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #7 of 18 (permalink) Old 07-07-2017, 06:50 AM Thread Starter
New Member
 
Join Date: Jun 2017
Posts: 50
my local dealer has a dyno and has already charged me 350.00 for resetting the TPS and a few other things,
the bike ran well till I got home.

Any way for a new bike it should work perfect,
this is really a poor way to have to go about making a new bike run properly

2013 Brutale 1090 RR ABS
Philly PA USA

Last edited by mrmerlin; 07-20-2017 at 09:34 PM.
mrmerlin is offline  
post #8 of 18 (permalink) Old 07-07-2017, 06:53 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,794
Send a message via Skype™ to silentservice703
The TPS rest is under 5 minutes of work. I would have done that for you free of charge.

I hope for that money you got dyno run time and extensive tuning. I think Rob will flash your ECU for under $300.00 to the mapping we developed with my 2010 1090RR.

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #9 of 18 (permalink) Old 07-09-2017, 08:35 PM Thread Starter
New Member
 
Join Date: Jun 2017
Posts: 50
Well i put about 250 miles on the Brutale today riding the back roads of eastern PA.
The bike needs a quick shifter, anyone have any suggestions on what one to add i have a rapid bike on my ECU system.
the cold starting issue is also a bummer as it stumbles and dies till the bike gets warm this takes about 4 mins.

After About 20 mins of riding fast avg 70mph, I notice that when accelerating the bike goes like hell,
once I get to a steady speed and roll off the throttle, to a cruise setting, the engine seems to burble and stutter almost like its now running out of fuel,
I have to add more throttle to get the engine to come alive again and accelerate, its like a on and off switch no subtle acceleration here.
Please tell me what this issue could be?


Here is my thought. The PO had the tank coated with the good tank coating when the bike was put into service,
I am wondering if somehow the fuel filter or pump may have been damaged with the coating material .

SO I am going to pull the tank off and inspect the fueling system,
replace the internal tank lines and the filter.
Anyone have any other suggestions?
Otherwise i really like the bike except for this crappy fueling issue and the shifting deal.

2013 Brutale 1090 RR ABS
Philly PA USA

Last edited by mrmerlin; 07-09-2017 at 08:40 PM.
mrmerlin is offline  
post #10 of 18 (permalink) Old 07-10-2017, 04:10 AM
Senior Member
 
lefin102's Avatar
 
Join Date: Jun 2015
Location: The United Peoples Republic ofNew Jersey
Posts: 658
if the bike ran great until you got it home did you let the dealer know about this? for $3,350 what did the service ticket say they did? who is the dealer?

even a blind squirrel gets a nut once in a while!!
lefin102 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome