2014 1090 problem - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 06-23-2017, 02:38 AM Thread Starter
Senior Member
 
Deano's Avatar
 
Join Date: Nov 2011
Location: Townsville, QLD
Posts: 778
New Site Garage
2014 1090 problem

G'day,

A mate of mine with the above is having problems. Bike wont start an reads 'error' on the dash when cranked. The neutral light doesn't come on. Neutral light had been intermittant and took 5-10seconds to show after switching ignition on. Since the neutral light's gone out no start. I've pulled the neutral switch out but not sure how to test it. Looks ok but the plug is too small to get probes in. Bike runs a Microtec from Chris at XBikes. Had been running fine but this occurred a couple of weeks after fitting Microtec. When when he tried to start it he had backfires etc. until the light went out and no go. Ideas?

C heers

Deano
Deano is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 06-23-2017, 06:24 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,823
Send a message via Skype™ to silentservice703
This might help (The manual is your friend)

Name:  B4 1090RR Start Circuitry.jpg
Views: 194
Size:  415.6 KB

Name:  B4 1090RR Neutreal Switch Diagnostics.jpg
Views: 196
Size:  425.5 KB

Name:  B4 1090RR Gear Position Switch Testing.jpg
Views: 205
Size:  378.7 KB

Name:  B4 1090RR Starter Diagnostics.jpg
Views: 204
Size:  375.2 KB

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #3 of 9 (permalink) Old 06-23-2017, 09:14 AM
New Member
 
Join Date: Apr 2017
Location: Chicago, IL
Posts: 39
How is the battery? I was getting some weird errors starting my 1090 when my battery was weak.
Fat Pat is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 06-23-2017, 07:46 PM
New Member
 
Join Date: Sep 2012
Posts: 55
Battery is fine fat pat, originally the light came on immediately, then later on it would take about 10 seconds to come on, but now it wont come on at all.
mvaussie is offline  
post #5 of 9 (permalink) Old 06-24-2017, 02:46 AM
New Member
 
Join Date: Sep 2012
Posts: 55
Thanks silentservice703, the bike is going to the local MV service agent on Tuesday and I am passing this on to him.
mvaussie is offline  
post #6 of 9 (permalink) Old 06-24-2017, 07:15 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,823
Send a message via Skype™ to silentservice703
Best of luck with it. Let us know the resolution, please.

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #7 of 9 (permalink) Old 06-29-2017, 03:55 AM
New Member
 
Join Date: Sep 2012
Posts: 55
Have not heard back from the service agent silentservice703, he is not known for his promptness and the last time I took it there it was about a month before he worked on it but I will let you know either way.
mvaussie is offline  
post #8 of 9 (permalink) Old 07-06-2017, 10:28 AM
New Member
 
Join Date: Jun 2017
Posts: 50
any updates?

2013 Brutale 1090 RR ABS
Philly PA USA
mrmerlin is offline  
post #9 of 9 (permalink) Old 07-28-2017, 04:32 AM
New Member
 
Join Date: Sep 2012
Posts: 55
Ok guys I finally got the bike back and here is what happened. I had a microtec fitted which really improved the fueling but when we mucked around with to fine tune it a bit more we must of made it too rich and the plugs fouled up so the mechanic fitted some new plugs and she is back running again. The neutral light issue is still a bit of a mystery as the way it is now the neutral light does not come on when you turn on the ignition but comes on as soon as the engine starts. The microtec was also removed and the standard ecu was fitted back on by the mechanic as I traded the bike in on a new KTM 1090r, so all I can report is we made it too rich which stuffed up the plugs and that is why it would not start, I had problems with the neutral light with the microtec but with the standard ecu its working although not as its meant to. I should of just been satisfied with the standard microtec settings and left it alone.
mvaussie is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome