what is this and what function does it serve - MVAgusta.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 09-24-2016, 12:41 PM Thread Starter
Senior Member
 
number2's Avatar
 
Join Date: Jan 2009
Location: Charleston South Carolina
Posts: 5,540
what is this and what function does it serve

I am not getting fuel through 1 of the lines on the bottom of the tank and this seems to be the culprit. If I remove it gas will come out of the opening where it is supposed to go. If it is installed and the tank primes the line remains bone dry.
Attached Images
 
number2 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 09-24-2016, 12:57 PM
New Member
 
Join Date: Aug 2016
Posts: 28
Fuel pressure regulator. Im not sure about the bike, but in a car a vacuum hose is attached to the smaller end which opens the valve further as vacuum is increased within the engine. So maybe the vacuum line has become disconnected somewhere or the regulator is faulty. Or possibly nothing to do with that part at all.
116618LN is offline  
post #3 of 11 (permalink) Old 09-24-2016, 01:06 PM Thread Starter
Senior Member
 
number2's Avatar
 
Join Date: Jan 2009
Location: Charleston South Carolina
Posts: 5,540
thanks. There has never been a hose attached even when it was working so. I tried blowing air through it but there is no air flow.
number2 is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old 09-24-2016, 01:15 PM
New Member
 
Join Date: Aug 2016
Posts: 28
It would only flow through the very center hole and the outer holes that ring around the center.

There would never be flow where the vacuum line would go as that is only a diaphragm.

If its blocked a new one should only be $30-$60. Bosch make a lot of FPR's so you can see if it has any markings on it to see what BAR it is and try and get one locally.
116618LN is offline  
post #5 of 11 (permalink) Old 09-24-2016, 03:44 PM Thread Starter
Senior Member
 
number2's Avatar
 
Join Date: Jan 2009
Location: Charleston South Carolina
Posts: 5,540
not sure what I did but it is working now.

Last edited by number2; 09-24-2016 at 07:00 PM.
number2 is offline  
post #6 of 11 (permalink) Old 09-24-2016, 07:01 PM Thread Starter
Senior Member
 
number2's Avatar
 
Join Date: Jan 2009
Location: Charleston South Carolina
Posts: 5,540
well I thought it was fixed but it is being starved for fuel
number2 is offline  
post #7 of 11 (permalink) Old 09-24-2016, 08:07 PM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 17,959
Send a message via Skype™ to esq'z me
That is the pressure regulator. On MV the vacuum hose is not attached. It functions on atmospheric pressure at a steady point.

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, 2015 Indian Chieftain (Rita) my "low-n-slow", '70 Suzuki F50 (Baby Blue), 2018 Suzuki GSX-S750L8 (Susie Q)
esq'z me is online now  
post #8 of 11 (permalink) Old 09-24-2016, 08:38 PM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,054
New Site Garage
Quote:
Originally Posted by number2 View Post
well I thought it was fixed but it is being starved for fuel
Two questions.
1. Are you sure the tank breather lines to the fuel cap is working as they should ?
2. Did you replace the male and female fittings on your fuel lines ?

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
post #9 of 11 (permalink) Old 09-25-2016, 09:19 PM Thread Starter
Senior Member
 
number2's Avatar
 
Join Date: Jan 2009
Location: Charleston South Carolina
Posts: 5,540
I checked everything again and it seems one of the lines may have been crimped. running fine now
number2 is offline  
post #10 of 11 (permalink) Old 09-26-2016, 01:27 AM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,054
New Site Garage
Cool.

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome