Brutale 910S Gauge Cluster - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 09-13-2016, 07:27 PM Thread Starter
New Member
 
Join Date: May 2016
Posts: 17
Brutale 910S Gauge Cluster

Was wondering if anyone had an issue with gauge cluster light being very dim, close to being out. I started my bike this evening and noticed that gauge cluster light was gone. I gave it some gas and it started back on (from vibration), however it was still rather dim. Tachometer seems to be off pretty much. Anyone had anything like that? Perhaps battery is going "bye-bye"?

Thanks.
Pyliokas is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 09-13-2016, 08:01 PM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,054
New Site Garage
Smile

Quote:
Originally Posted by Pyliokas View Post
Was wondering if anyone had an issue with gauge cluster light being very dim, close to being out. I started my bike this evening and noticed that gauge cluster light was gone. I gave it some gas and it started back on (from vibration), however it was still rather dim. Tachometer seems to be off pretty much. Anyone had anything like that? Perhaps battery is going "bye-bye"?

Thanks.
If your bike is starting and running fine I imagine the battery is fine. Have you tried cleaning the connections behind the dash ?

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
post #3 of 8 (permalink) Old 09-13-2016, 08:06 PM Thread Starter
New Member
 
Join Date: May 2016
Posts: 17
Quote:
Originally Posted by Donsy View Post
If your bike is starting and running fine I imagine the battery is fine. Have you tried cleaning the connections behind the dash ?
I take it you mean the main connector going to the back of the cluster?
Pyliokas is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 09-14-2016, 01:56 AM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,054
New Site Garage
Yup.

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
post #5 of 8 (permalink) Old 09-14-2016, 06:43 PM Thread Starter
New Member
 
Join Date: May 2016
Posts: 17
Quote:
Originally Posted by Donsy View Post
Yup.
Just tried it, unfortunately that didn't help. It is not that the entire light is dim, it is like top right corner that is dim. Really weird.
Pyliokas is offline  
post #6 of 8 (permalink) Old 09-14-2016, 07:41 PM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,054
New Site Garage
Open the dash, it's very easy, there are "globes"/"bulbs" inside which can blow and which can be repaired or replaced.
I think there's a few threads on this topic in the Customising section mate.

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
post #7 of 8 (permalink) Old 09-14-2016, 09:35 PM Thread Starter
New Member
 
Join Date: May 2016
Posts: 17
Quote:
Originally Posted by Donsy View Post
Open the dash, it's very easy, there are "globes"/"bulbs" inside which can blow and which can be repaired or replaced.
I think there's a few threads on this topic in the Customising section mate.
Looked around and found a post showing a guy changing them. I'll disassemble and check it out first, but hopefully a replacement will help. Thank you Sir!
Pyliokas is offline  
post #8 of 8 (permalink) Old 09-17-2016, 10:35 PM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,054
New Site Garage
Thumbs up

Quote:
Originally Posted by Pyliokas View Post
Looked around and found a post showing a guy changing them. I'll disassemble and check it out first, but hopefully a replacement will help. Thank you Sir!
No worries mate, it's a pretty easy to work on system, just be carefull with the rev counter needle.

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome