coolant leak - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-27-2016, 08:05 PM Thread Starter
New Member
 
Join Date: Jan 2016
Posts: 3
coolant leak

2014 Brutale 675

My coolant is constantly leaking from the overflow tube. I thought it might be from idling around in traffic too long but it keeps leaking after I refill the tank. No signs of leaks anywhere else.

Has anybody experienced this issue? Is it something to do with the thermostat?
figsclay is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-27-2016, 08:35 PM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,054
New Site Garage
Hahaha, 4 cylinder 675, must be new model. Have a look in the next section down buddy. Lots of discussions on this very topic.
Most probably simply emptying out excess fluid since you should be running the level on low, but it could be a faulty cap or air in the system too.

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
The Following User Says Thank You to Donsy For This Useful Post:
post #3 of 4 (permalink) Old 06-28-2016, 08:09 AM
Senior Member
 
Wildfire's Avatar
 
Join Date: Mar 2014
Location: London, UK
Posts: 465
As Donsy says, could be an airlock or faulty cap, but the triples do run on minimal coolant, so if you're topping up all the time it may just be emptying out what you put in.
Wildfire is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 06-28-2016, 10:10 AM
Senior Member
 
PhilAgusta's Avatar
 
Join Date: Aug 2010
Location: FV, CA
Posts: 1,723
Quote:
Originally Posted by figsclay View Post
2014 Brutale 675

My coolant is constantly leaking from the overflow tube. I thought it might be from idling around in traffic too long but it keeps leaking after I refill the tank. No signs of leaks anywhere else.

Has anybody experienced this issue? Is it something to do with the thermostat?
this is what I do to all the bike I owned, take off the coolant cap start your bike let run to temp 150 degree turn off your bike, then lean your bike to the left shake it couple times and lean your bike to the right shake it couple times then turn your bike on again let it run to temp 160 degree do the same as first step then refill to your coolant to Minimum requirement level recap it ready to go


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

07-MV Senna 201/300 My wife gift for my BD
05-MV F4 Track bike
16-Ducati DVT-S
10-Ducati 1198R
08-Ducati 1098
09-Ducati 848 Her bike turn in track bike
PhilAgusta is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome