Relay problems help! - MVAgusta.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 83 (permalink) Old 06-16-2016, 06:40 PM Thread Starter
Relay problems help!

Hi people of mv agusta . Net!

Recently and finally insured by f4 750 which is a pleasure and aching to ride, unfortunetly one of my relays is playing up (bitron PA66-GF30 5 pin) which I cant seem to find anywhere! Ive bought a generic one from maplins and the bike turns on starts up even without ignition or keys inserted!!! Madness! Which I thougt that this tells me that the little diode is not blown? The maplins relay has a different layout compared to oem (bitron) was told that mine is a 2 pole double contact relay???? Any help or suggestions or spare laying around would be great! Added a picture of layout

Regards
Attached Images
 
Martini_and_lime is offline  
Sponsored Links
Advertisement
 
post #2 of 83 (permalink) Old 06-16-2016, 08:03 PM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,054
New Site Garage
You need to have the right diode protected double pole relay mate. How do you know the relay is playing up, are you sure your battery was not low ? Did you disconnect and reconnect your battery at any stage ?

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
post #3 of 83 (permalink) Old 06-17-2016, 04:56 AM Thread Starter
so does the relay have a diode inside? because there is one on the connection which goes into the relay? I opened the relay up and connected it back up and its not moving to make contact (if that makes any sense) if I make a connection by moving the little plate bike starts up, I disconnected the battery as I thought it was flat but it was fully charged, might of touched the frame with red wire not sure - but it still started with the other relay from maplins which has different layout and no diode? Very confusing
Martini_and_lime is offline  
Sponsored Links
Advertisement
 
post #4 of 83 (permalink) Old 06-17-2016, 05:02 AM Thread Starter
Martini_and_lime is offline  
post #5 of 83 (permalink) Old 06-17-2016, 05:10 AM Thread Starter
* forgot to mention that even before the battery check the bike/ignition was not lighting up - after shaking the relay it would click on/work
Martini_and_lime is offline  
post #6 of 83 (permalink) Old 06-17-2016, 05:26 AM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,054
New Site Garage
Yes and Yes.
Did you have a look at the electrical drawings in the Workshop manual, I assume you're working with the General Feed relay (20) ?

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
post #7 of 83 (permalink) Old 06-17-2016, 06:54 AM Thread Starter
yep its listed as the general feed relay number 20 thats correct, do you think that the ebay listed relay will work or should I keep searching as it does not have a 87b listed? not sure if that makes any difference!

so much hassle for a stupid relay arghhh
Martini_and_lime is offline  
post #8 of 83 (permalink) Old 06-17-2016, 07:21 AM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,054
New Site Garage
Thumbs up

I did say yes , I think it could work, it's just the second contact so as long as the pins are similar you should be ok.
It's not stupid or very strange, quite common actually.

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
post #9 of 83 (permalink) Old 06-17-2016, 09:04 AM Thread Starter
ok cheers will go ahead and purchase and will update once installed!!!

Many thanks
Martini_and_lime is offline  
post #10 of 83 (permalink) Old 06-17-2016, 09:10 AM Thread Starter
just noticed that the 30a is labelled at the bottom pin on mine and on the ebay one its on the side? please correct me cheers
Martini_and_lime is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome