have I fixed the oil pressure problem - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-04-2016, 03:05 PM Thread Starter
New Member
 
Join Date: May 2016
Location: Nottingham, UK
Posts: 8
have I fixed the oil pressure problem

Hi Guys, Im new to this site. Im new to MV too, bought myself a Dragster and loved it so much I've just bought an F4RR 312.
This morning the oil light came on. I whipped the panels off and unclipped the sensor. Gave it a wipe and popped it all back together. The light is out.
Oil is new and right level. When i ran the engine the level altered so I'm assuming the mechanics are all good.
Shall I work on the basis its all good now or is there a possibility that Ive just disconnected the sensor and the light has gone out? i.e. if its not connected properly, would the light stay on?
Cheers
Dom
domsh is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-04-2016, 03:56 PM
Senior Member
 
revhead1957's Avatar
 
Join Date: Apr 2011
Location: Brisbane, Australia
Posts: 1,567
Welcome aboard the MV Express.
I think you are safe. probably change that sensor at some stage.
It is worthwhile going around every connector and luring with dielectric grease.
revhead1957 is offline  
post #3 of 5 (permalink) Old 05-04-2016, 06:54 PM
Senior Member
 
theknurl's Avatar
 
Join Date: Jul 2009
Location: Palos Verdes Est, SoCal, USA
Posts: 13,799
Send a message via Skype™ to theknurl
Thumbs up ?

domsh;

the oil pressure sending unit is a GM part its available for ~$9.....

AC Delco Part # 93190643



Noel-theknurl

The Forum Curmudgeon
I'm not PC either
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R
'05 F4
ph. 310-414-7247 PST, GMT -8
PayPal;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Skype; theknurl

Last edited by theknurl; 05-04-2016 at 10:21 PM.
theknurl is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 05-04-2016, 07:14 PM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,054
New Site Garage
http://www.mvagusta.net/forum/showthread.php?t=50682

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
post #5 of 5 (permalink) Old 05-05-2016, 02:46 PM Thread Starter
New Member
 
Join Date: May 2016
Location: Nottingham, UK
Posts: 8
Thanks guys, all seemed good today!
domsh is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome