910R Surging - MVAgusta.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 03-07-2016, 01:03 AM Thread Starter
New Member
 
thegribbs's Avatar
 
Join Date: Jan 2016
Location: Newcastle, NSW
Posts: 10
910R Surging

I've been reading these forums for a few months now and I think I'd better introduce myself, seeing as I have a 910R of my own (thanks to Mick De V). The bike is amazing, everything I'm after. In the past month or so of owning it I've put 4000km on it though twisty roads and doing chores around town.


There is one problem I'm having though. Once the bike is hot, say above 90*C, it surges. The RPM goes up and down in waves and being forced to use the clutch to keep upright on low speed turns.
On a cool day it sits around 87*C and feels smooth. If I stop and let it heat up for any amount of time it reverts to surging. The surge is also noticeable at idle.

I had a good search and these sort of problems are usually solved with tuning, but that has already been done with the Microtec and a good amount of dyno time.

My first thoughs before I discovered the issue is heat related were to look at the TPS. If anybody can point me in the right direction that would be great.

Cheers
thegribbs is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 03-07-2016, 01:12 AM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,054
New Site Garage
Welcome Alex.
Sounds like a bit of a heat / map related issue, the ECU changes the mapping once the temp goes over a pre-determined temp, this could be your issue. It might be a temp compensating issue in the mapping and only a dyno tuner will find this.
What fuel are you running, should be a 95 if that is what they used to tune the bike with, and is your fans coming on?
The TPS is not adjustable on your bike, and is the round little black thing on the r/h side of your throttle bodies.
You will see it illustrated in the workshop manuals which you can download from my website.

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
post #3 of 15 (permalink) Old 03-07-2016, 01:29 AM Thread Starter
New Member
 
thegribbs's Avatar
 
Join Date: Jan 2016
Location: Newcastle, NSW
Posts: 10
Thanks Donsy,
The bike is tuned for 98, which I always use.
Fans are coming on at 95*C
Yeah, when I said TPS I was thinking throttle bodies. Do you think it is worthwhile checking before I spend the $$$ at the shop? I have all the tools to check them.
thegribbs is offline  
Sponsored Links
Advertisement
 
post #4 of 15 (permalink) Old 03-07-2016, 01:50 AM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,054
New Site Garage
Throttle body balancing will not change between a hot and cold bike, if they're out, it will affect the bike at all temps if you know what I meant Alex ?

Have you got access to your Microtec, if you do then set the fans to come on at 90*C and see if that will help.

Do you know how old the plugs are ?

There is another wild stab, if all else fails.
A battery running low or a weak battery will affect the running of the bike when the fans come on, this is often solved by replacing the battery obviously, but sometimes it can be something as little as replacing the battery mains cables as some guys have discovered.

http://www.mvagusta.net/forum/showthread.php?t=102666

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
post #5 of 15 (permalink) Old 03-07-2016, 02:23 AM
Senior Member
 
eddypro's Avatar
 
Join Date: Feb 2011
Location: brisbane
Posts: 3,493
It really is a chasing game ,Donsy is spot on ,You can if you so desire is to sync the throttle bodies in a different manner ,by memory never touch the 2 throttle bodies on the tps side ,ever. the other 2 on the other side can be adjusted with the screw in the middle ,with a gauge you can get them closed at the precise point,basically lh and rh throttle bodies being perfect when closed.if you do this mark all reference points.Better to take the bodies off the bike when doing this.Then hold them up to a light and you will see how crappy they are.Be warned do at your on peril.

Also you could sync the throttle bodies using a good carbtune.

also you could let more air into the bike at idle by adjusting the air bleed valves ,say 1 turn out wich should increase your idle rpm.

With the microtec Chris from X-bikes is the guru,maybe send him a Pm .

I would do as Donsy suggested first.

I am only suggesting certain options here and no responsibility taken as i am running Pc5 and running a different bike.
what coolant are you using, I just use water and 25 percent anti corrosion solution.Water is your best coolant.

cheers eddy
eddypro is offline  
post #6 of 15 (permalink) Old 03-07-2016, 02:34 AM Thread Starter
New Member
 
thegribbs's Avatar
 
Join Date: Jan 2016
Location: Newcastle, NSW
Posts: 10
The plugs are iridium and have ~16k on them.
The battery is sitting at 12.7v.
I'll contact Microtec and get the software. I already have the CAN to USB adapter.
thegribbs is offline  
post #7 of 15 (permalink) Old 03-07-2016, 02:44 AM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,054
New Site Garage
Smile

Quote:
Originally Posted by thegribbs View Post
The plugs are iridium and have ~16k on them.
The battery is sitting at 12.7v.
I'll contact Microtec and get the software. I already have the CAN to USB adapter.
Recon those plugs are old.
Don't bother with Microtec, you'll be wasting your time.
Contact Chris (X81 here on the forum) or the guys who did the install for Mick, he might still have the disc/CD ?
http://www.mvagusta.net/forum/member.php?u=3979

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Donsy; 03-07-2016 at 02:47 AM.
Donsy is offline  
post #8 of 15 (permalink) Old 03-07-2016, 03:32 AM Thread Starter
New Member
 
thegribbs's Avatar
 
Join Date: Jan 2016
Location: Newcastle, NSW
Posts: 10
Eddy, Donsy, thanks for the help. At least I've got some direction now.

I'll keep you posted after I check these things out.
thegribbs is offline  
post #9 of 15 (permalink) Old 03-07-2016, 06:04 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,823
Send a message via Skype™ to silentservice703
A question: Does it surge throughout the rev range, or only 4k and below?

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #10 of 15 (permalink) Old 03-07-2016, 06:26 AM Thread Starter
New Member
 
thegribbs's Avatar
 
Join Date: Jan 2016
Location: Newcastle, NSW
Posts: 10
I notice it less above 5.5k, though the other day I was maintaining about 7k through a corner when things started to get choppy. Below 5ish its more noticable and feels as though for a fraction of a second power drops, like losing spark I guess.

Last edited by thegribbs; 03-07-2016 at 06:29 AM.
thegribbs is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome