No Lights or Horn - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-07-2013, 01:04 AM Thread Starter
New Member
 
Join Date: Aug 2013
Location: Las Vegas
Posts: 41
Red face No Lights or Horn

This is a long story that started the day I left the dealer and is a saga that is ongoing to this day. This is the story of why I've been riding a Triumph Street triple. Just putting this out there in case any body has this problem in the future.
The day I rode my B3 home I had my buddy who took me to the dealership follow me home. After we arrived at my house my buddy got out of the truck and said "you should probably start using your turn signals or you might die. And how did you get all the way home with out using your brakes."
I said that's funny because I did. After 15 minutes of reading the manual to make sure I knew how to use the turn signals and horn (same wire harness) I called the dealer. They drove the 45 Min to my house to trouble shoot the problem in the garage. 2 Hrs and 10 blown fuses later it left on his trailer. The mechanic worked threw the night and into Sunday morning. They drove the 45 Min back to deliver it on Sunday. IT WORKED! He said they found a bare wire....... for 7 miles it worked. So back it went. The mechanic removed the entire wire harness for the brake lights, turn lights and horn. Which was a big undertaking that left my bike looking like a frame with wheels next to a pile of parts. All this work revealed some shorts in the wire harness . Back together it came home for a total of 4 days. Then it left again. With more miles on the back of a trailer then miles ridden.....they called "Italy" for help. Those of you not familiar Italians, they don't usually work in August and didn't make a special exception for me. So now Sept is here and my new wire harness is in the mail. Hope to have it in 3 weeks. The dealer feels horrible and has given me a Triumph to ride in the mean time.
Can't wait to get my bike fixed and start installing the parts that are piling up in the garage....Well I have a tail tidy, radiator guard and bar weights.

RUDY

RUDY
_______
Mv Agusta '13 1090

Last edited by TaskforceRudy; 09-07-2013 at 02:04 AM.
TaskforceRudy is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-17-2013, 12:49 AM Thread Starter
New Member
 
Join Date: Aug 2013
Location: Las Vegas
Posts: 41
Still no bike, BUT MV is on the case now. So hopefully soon

RUDY
_______
Mv Agusta '13 1090
TaskforceRudy is offline  
post #3 of 3 (permalink) Old 09-17-2013, 09:58 AM
Banned
 
Join Date: Sep 2013
Posts: 676
Angry Good gods

"for 7 miles it worked. So back it went. The mechanic removed the entire wire harness for the brake lights, turn lights and horn. Which was a big undertaking that left my bike looking like a frame with wheels next to a pile of parts. All this work revealed some shorts in the wire harness ."

Yuk. Somebody in Italy had a bad night with the mistress and the wife and somebody's rat dog.
Dana Kincaid is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome