Clear Alternative rear light (help!) - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 02-19-2007, 04:57 PM Thread Starter
Senior Member
 
clandestinejinx's Avatar
 
Join Date: Oct 2006
Location: Beautiful Cecilia LA
Posts: 330
Clear Alternative rear light (help!)

Where in gods name am I supposed to mount or install this factory relay? I found the instructions to be shoddy and found no relay bank under the tank as stated in the weird sticker instruction. Also had to use a volt meter to find out wich wire to connect the yellows to and am heading to Radio Shack to build some connectors as the ones provided are the crimp type that put gaps in the insulation on the wires.

Anyway, where the hell does the relay go? How do I put it in. Called Clear Alternatives and got the fax all day.
clandestinejinx is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 02-19-2007, 04:59 PM
Senior Member
 
airfuel's Avatar
 
Join Date: Feb 2006
Location: Connecticut
Posts: 1,292
You don't use the relay on the Brute. Just wire it up and it will work fine.

John T
Certified Power Commander Tech.
Authorized Tuning Center/Dealer


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
airfuel is offline  
post #3 of 7 (permalink) Old 02-20-2007, 08:34 AM Thread Starter
Senior Member
 
clandestinejinx's Avatar
 
Join Date: Oct 2006
Location: Beautiful Cecilia LA
Posts: 330
I am not sure about that but I will try to contact Clear Alternative and see.
clandestinejinx is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 02-20-2007, 08:45 AM
 
Join Date: Feb 2006
Posts: 456
Always trust in John. All you need to do is wire it up. You do not need the relay. I have the clear alternatives rear light. That's all I did.
MVITALIAN is offline  
post #5 of 7 (permalink) Old 02-20-2007, 09:43 AM
 
Join Date: Aug 2006
Posts: 140
Motovation has written their own install sheet. Maybe this is better. Click on Install link on page:

Brutale CA Tailight Install Isntructions
kilat is offline  
post #6 of 7 (permalink) Old 02-20-2007, 10:44 AM
Senior Member
 
mike21's Avatar
 
Join Date: Jun 2006
Location: Sajaniemi Finland
Posts: 720
Quote:
Originally Posted by clandestinejinx
Where in gods name am I supposed to mount or install this factory relay? I found the instructions to be shoddy and found no relay bank under the tank as stated in the weird sticker instruction. Also had to use a volt meter to find out wich wire to connect the yellows to and am heading to Radio Shack to build some connectors as the ones provided are the crimp type that put gaps in the insulation on the wires.

Anyway, where the hell does the relay go? How do I put it in. Called Clear Alternatives and got the fax all day.
Mine is looking like this after installation...the resistor is for reducing the blinking tempo..i left mine blinking faster.that is i didnt use the resistor.Mine is from eMoto.uk and there was not any relay???only the resistor.Just follow the instruction it should be quite easy..
Attached Images
 

Starfighter Titanium R
Ducati 998S

mike21 is offline  
post #7 of 7 (permalink) Old 02-20-2007, 01:03 PM Thread Starter
Senior Member
 
clandestinejinx's Avatar
 
Join Date: Oct 2006
Location: Beautiful Cecilia LA
Posts: 330
Instructions were crappy but Arifuel was right about the flasher module. Cant use it. Finally got ahold of them.
clandestinejinx is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome