Fuel leak...bad - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 08-19-2013, 10:08 AM Thread Starter
New Member
 
Join Date: Apr 2010
Location: NYC
Posts: 49
Fuel leak...bad

Took my Brutale out for a quick ride last week...pulled over to get gas...pull out of the gas station and noticed the throttle was twitchy...look down and there is gas pouring out of the left side of the bike...and i mean pouring! anyone have any idea what would cause this?
The bike is now back at GoldCoast waiting to hear what is up.

Current
2010 Brutale
Past
2004 R1
1996 CBR
Turok is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 08-19-2013, 10:13 AM
Senior Member
 
Resom's Avatar
 
Join Date: May 2010
Posts: 272
I imagine one of the plastic fuel fitting QD's broke. They and the fuel lines they're attached to are suppose to be changed every 2 years, according to MV - believe it or not!

I bought some spares. Expensive bits.....$80/each (molded Fuel Line w/QD attached).

Good luck.
Resom is offline  
post #3 of 7 (permalink) Old 08-19-2013, 12:42 PM Thread Starter
New Member
 
Join Date: Apr 2010
Location: NYC
Posts: 49
Quote:
Originally Posted by Resom View Post
I imagine one of the plastic fuel fitting QD's broke. They and the fuel lines they're attached to are suppose to be changed every 2 years, according to MV - believe it or not!

I bought some spares. Expensive bits.....$80/each (molded Fuel Line w/QD attached).

Good luck.
Thats helpful...thx

Current
2010 Brutale
Past
2004 R1
1996 CBR
Turok is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 08-19-2013, 06:14 PM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 18,411
Send a message via Skype™ to esq'z me
Very possible the fuel cap water drain hose has parted near the cap area inside the tank. When you filled up it began leaking out the drain hose on the left side of the bike where it is routed.

Wouldn't be the gas cap vent hose, as that would flood the evap canister and cause horrid running condition (unless the evap system has been removed)...US models only.

E10 gasoline rots the hoses eventually. Happened to me on my 910R. I plugged the hose with a cigarette filter butt off the ground so I could get home without catching on fire. Once the fuel level dropped to about 3/4 full the leaking stopped. The broken off end of the hose was above the fuel.

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, '70 Suzuki F50 (Baby Blue)
esq'z me is offline  
post #5 of 7 (permalink) Old 08-19-2013, 07:16 PM
Senior Member
 
theknurl's Avatar
 
Join Date: Jul 2009
Location: Palos Verdes Est, SoCal, USA
Posts: 14,041
Send a message via Skype™ to theknurl
Wink she's a leaker

Turok;
its like Ed said or like Resom did but replace the plastic quick disconnects anyway with metal ones from Alex at Gutsy Performance a Forum Sponsor

Noel-theknurl

The Forum Curmudgeon
I'm not PC either
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R
'05 F4
ph. 310-414-7247 PST, GMT -8
PayPal;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Skype; theknurl
theknurl is offline  
post #6 of 7 (permalink) Old 11-27-2013, 06:54 PM
New Member
 
RVRC_313's Avatar
 
Join Date: Nov 2013
Posts: 3
Angry Same issue here

I just bought mine about 4 days ago and while I was riding I started fish tailing for nothing. I stop thinking I had a flat but it was gas coming on the left side like crazy....
RVRC_313 is offline  
post #7 of 7 (permalink) Old 11-28-2013, 12:39 PM
Senior Member
 
Red Baron's Avatar
 
Join Date: Sep 2012
Location: San Diego, north county
Posts: 1,150
Quote:
Originally Posted by RVRC_313 View Post
I just bought mine about 4 days ago and while I was riding I started fish tailing for nothing. I stop thinking I had a flat but it was gas coming on the left side like crazy....
Year and model?
Red Baron is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome